Results 1 to 6 of 6

Thread: Error airmon-ng

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010

    Default Error airmon-ng

    hey guys
    at first I want to apologize for my poor english skills .
    I'm trying to describe my situation and problem.
    I downloaded backtrack 4 final and did it to a usb stick with unetbootin. While booting I
    get an error: EXT3-fs Sda6 couldn't mount because unsupported optional features (240)
    after waiting several seconds the shell appears. But a login attempt with root as username and toor as password failed. But this is not my main problem because I could start it with the command "startx"
    After that I opened the shell and tried several commands:
    Network controller: Intel Corporation WiFi Link 1000 Series

    Wlan0 IEEE 802.11bgn ESSID:"" Mode: Monitor ...(I think irrelevant)

    airmon-ng start wlan0:
    wlan0 Intel 4965/5xxx iwlagn - [phys0]SIOCSIFFLAGS: No such file or directory
    (monitor mode enabled on mon0)

    airodum-ng mon0:
    ioctl(SIOCSIFFLAGS) failed: No such file or directory

    these bold messages are my problems.
    I googled the las error message and got to the page of aircrack:faq [Aircrack-ng]

    Why do I get ioctl(SIOCGIFINDEX) failed: No such device ?

    Double check that your device name is correct and that you haven't forgotten a parameter on the command line.

    When using linux-wlan-ng driver, be sure to enable the interface first with airmon-ng.
    I think I didn't do anything wrong. Hope you can help me.

    greets xparet0209

  2. #2
    Good friend of the forums gunrunr's Avatar
    Join Date
    Jan 2010
    shining my spoon

    Default Re: Error airmon-ng

    what is airodum_ng? make sure that you are inputting the commands correctly.
    Wielder of the spoon of doom
    Summercon, Toorcon, Defcon, Bsides, Derbycon, Shmoocon oh my
    Come hang out with hackers on twitter @gunrunr556

  3. #3
    Just burned his ISO
    Join Date
    Oct 2010

    Default Re: Error airmon-ng

    try airodump-ng

  4. #4
    Just burned his ISO
    Join Date
    Oct 2010

    Default Re: Error airmon-ng

    oh this was my fault. it should be airodump-ng mon0 ofcourse

  5. #5
    Just burned his ISO
    Join Date
    Oct 2010

    Default Re: Error airmon-ng

    no ideas? -the problem still remains
    i tried aircrack with ubuntu and patched drivers -they work perfectly
    but why backtrack doesn't work?
    the drivers are already patched right?

  6. #6
    Just burned his ISO
    Join Date
    Jul 2010

    Default Re: Error airmon-ng

    If you just recently updated your kernel, then try this link for a fix:

Similar Threads

  1. Replies: 1
    Last Post: 09-29-2009, 09:50 AM
  2. Ugly error from airmon-ng
    By caballero in forum OLD Newbie Area
    Replies: 2
    Last Post: 07-31-2008, 04:28 AM
  3. Replies: 1
    Last Post: 07-28-2008, 05:44 PM
  4. airmon-ng script error (Lenovo T60)
    By JoopKnoop in forum OLD BT3beta Software related issues
    Replies: 0
    Last Post: 12-30-2007, 05:13 PM
  5. airmon-ng error
    By GrayFox.i0n in forum OLD Newbie Area
    Replies: 3
    Last Post: 12-24-2007, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts