Hi Community
I have used both BT3, and BT4 and I have cracked my own WEP twice in the same evening. Feeling pleased with myself I closed the PC and went to bed. The next day trying to show my friend how unsafe WEP is I could not repeat the process. On the aireplay-ng konsol the data was staying at 0 thus there was no IVs for aircrack-ng to work with. As far as I know I have not done anything different to the first couple of times that I cracked my WEP. I had a problem with my AWUS036H not being able to inject packets in BT4, that did not prevent WEP cracking just made it slower, but that was solved when i updated BT4.
Here are the steps I follow-
root@bt:~# airmon-ng

to check interfaces

airmon-ng stop wlan0
ifconfig wlan0 down
macchanger --mac 00:11:22:33:44:55 wlan0
airmon-ng start wlan0

the end result is this

Interface Chipset Driver

wlan0 RTL8187 rtl8187 - [phy0]
(monitor mode enabled on mon0)
An additional question would be from now on which interface should i use wlan0, or mon0. I have used both and still get the same problem I have read that I should use mon0. But could someone confirm that. Or does it not make a difference.

when i now use airodump-ng -c -w bssid wlan0 to fix on an AP i get the fix but the data stays at 0. When i first cracked my WEP this went into the 1000s straight away.

when i use aireplay-ng -1 0 BSSID -h 00:11:22:33:44:55 wlan0 to do a fake authetication things are normal.
aireplay-ng -3 -b BSSID -h works, but has got no data to work with...
and thus aircrak-ng has also nothing to work with.
this is how i cracked my own WEP twice the first time, and its what i did the following day and nothing. So i dont understand what the problem is.
I run BT4/BT3 on VMware player on a vista home premium 32 host.
I get this problem in BT3 and BT4.
I hope someone can point me in the rigth direction.
thanks for your time