Results 1 to 2 of 2

Thread: BACTRACK 4R1 and CHIPSET RT3092

  1. #1
    Just burned his ISO
    Join Date
    Oct 2010
    Madrid, Spain

    Default BACTRACK 4R1 and CHIPSET RT3092

    Hi, all,

    I have recently bought a HP Pavilion Elite 101-ES, which includes a built-in PCI-e Wifi device. After booting BT4R1 and performing lspci, i can see the dev is built with a RALINK RT-3092 chipset.

    So far, I cannot get it working. Once I start networking (/etc/init.d/networking start), I get a wlan0 interface (I can see it in a "ifconfig" as well as in a "iwconfig" printout), but it's labeled as an "ethernet (802.3)" interface. It seems quite strange to me, as the system is able to display the device's MAC... On the other hand, the graphical GUI networking apps simply doesn't show this wlan0. The only devices shown are my eth0 and lo0. I have tried this all with my ethernet unplugged (I know that in some Linux distributions, having eth0 up prevents some apps to activate wlan0), but wlan0 simply doesn't show up. So the device is strangely half-working: it seems that BT4 detects it, but it doesn't fully work.

    The driver automatically loaded by BT4 is rt2x00_pci; reading in some Ubuntu Forums, I have seen that a lot of people is working with RT3092, using the RT2860sta driver. I have tried to remove 2x00_pci (modprobe -r), and replace it with RT2860sta, but once I exec the modprobe -r 28xx_pci, the system hangs, and I can't event type with the keyboard.

    As a first stage, I would like to get my wifi device working normally in BT4. Then, I would like to find out whether it can get into monitor mode, or perform traffic injection. I don't feel confident trying this second stage, if I am not even able to work normally with the device.

    Has any of you worked with RT3092 chipset and BT4? Any hints?

    Note: This is my first post in the forum. If I had done any mistake, or if this is not an appropiate formatted question (as I have not attached the printouts of any command, for example), please let me know. On the other hand, I am not very skilled with written English...

    Thanks a Lot,


  2. #2
    Just burned his ISO
    Join Date
    Oct 2010
    Madrid, Spain

    Default Respuesta: BACTRACK 4R1 and CHIPSET RT3092

    No hints, guys?... This must be worse than I thought...

    Thanks a lot, anyway.

Similar Threads

  1. bactrack 4 wpa setup
    By panikman09 in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 1
    Last Post: 04-27-2009, 07:04 PM
  2. bactrack 3 in kemuPDL
    By t_virus in forum OLD Newbie Area
    Replies: 5
    Last Post: 01-20-2009, 07:37 AM
  3. RTL8187 bactrack 3
    By fido13uk in forum OLD BT3beta General
    Replies: 10
    Last Post: 05-13-2008, 03:24 AM
  4. Bactrack without LILO
    By coder86 in forum OLD Newbie Area
    Replies: 1
    Last Post: 07-14-2007, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts