Hello BackTrack community.

I've been experimenting a bit with BackTrack a while ago and recently decided to give it a try again as i just bought (by mistake) the AWUS036NH (instead of the AWUS036H).
I have BackTrack 4 R1 installed in VMware with Win 7 as host.
After hours of experimenting to get it to work i finally managed to get packet injection working by following these guidelines:
(Thanks to fnord0 for providing!)

cd /usr/src/drivers
wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-04-20.tar.bz2
 tar jxvf compat-wireless-2010-04-20.tar.bz2
cd compat-wireless-2010-04-20
wget http://patches.aircrack-ng.org/mac80211_2.6.32.2-wl_frag+ack_radiotap.patch
cat mac80211_2.6.32.2-wl_frag+ack_radiotap.patch | patch -p1
make install
make unload
modprobe rt2800usb
and finally, aireplay-ng --test wlan0 gave a positive response.

Happy with the result, i shut down my computer and went to bed. But when i started BackTrack again today, it wasn't working.
After much frustration i tried following the guidelines again and now it works again.
Can you tell me what to do to make it work PERMANENTLY?
It's quite annoying.

Thanks in advance!