Results 1 to 4 of 4

Thread: AWUS036NH working, then NOT working.

  1. #1
    Just burned his ISO
    Join Date
    Sep 2010

    Default AWUS036NH working, then NOT working.

    Hello BackTrack community.

    I've been experimenting a bit with BackTrack a while ago and recently decided to give it a try again as i just bought (by mistake) the AWUS036NH (instead of the AWUS036H).
    I have BackTrack 4 R1 installed in VMware with Win 7 as host.
    After hours of experimenting to get it to work i finally managed to get packet injection working by following these guidelines:
    (Thanks to fnord0 for providing!)

    cd /usr/src/drivers
     tar jxvf compat-wireless-2010-04-20.tar.bz2
    cd compat-wireless-2010-04-20
    cat mac80211_2.6.32.2-wl_frag+ack_radiotap.patch | patch -p1
    make install
    make unload
    modprobe rt2800usb
    and finally, aireplay-ng --test wlan0 gave a positive response.

    Happy with the result, i shut down my computer and went to bed. But when i started BackTrack again today, it wasn't working.
    After much frustration i tried following the guidelines again and now it works again.
    Can you tell me what to do to make it work PERMANENTLY?
    It's quite annoying.

    Thanks in advance!

  2. #2
    Just burned his ISO
    Join Date
    Mar 2009

    Default Re: AWUS036NH working, then NOT working.

    If this is anything like the problem with the AWUS036H issue, the key to making the fix permanent is editing the blacklist file located at /etc/modprobe.d/blacklist. Look for the blacklist snd_desktop section and make sure to blacklist the driver your card was originally using that gave you issues. Also, make sure that the new driver that fixed the issues is NOT blacklisted. I could be wrong though, I'm still new to linux.

  3. #3
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010

    Default Re: AWUS036NH working, then NOT working.

    Have you downloaded the VMware version? Or did you installed from the ISO?

  4. #4
    Just burned his ISO
    Join Date
    Jan 2011

    Unhappy Re: AWUS036NH working, then NOT working.

    hi im not sure if im posting this in the right place but i did get the awus036nh to work on both ubuntu and backtrack. the only problem i have is that after like 5 min of runnig airodump-ng it like freezes and acts like it its working at all but it does i unplug it and wait and plug it back in and it works for 5 mins if ne one can help me plz i been dealin with this awus036nh for two months

Similar Threads

  1. Replies: 1
    Last Post: 07-26-2010, 10:59 PM
  2. DNS Spoofing is working/working not!
    By htons139 in forum Beginners Forum
    Replies: 3
    Last Post: 05-19-2010, 08:20 PM
  3. Apt-get not working
    By BattZ in forum OLD Newbie Area
    Replies: 7
    Last Post: 12-15-2009, 07:05 PM
  4. Belkin F5D7050e - Confirmed working/Not working?
    By Beanz in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-07-2008, 06:53 PM
  5. IBM Think Pad R20 - Working
    By Donciccio in forum OLD BT3beta WORKING HARDWARE
    Replies: 0
    Last Post: 12-15-2007, 12:09 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts