After 5 hours of search>try>config>fail>clean , I feel lost!

BCM4313 802.11b/g LP-PHY [14e4:4727] chip is picked up by "wl" driver by default. it works well for normal usage, but rfmon/injection is NOT possible with this driver on this chipset.

Possible solution could be using b43 driver module instead, which I tried almost any trick/method on internet for that. b43 successfully loads, but it`s not picking up the chip and so no interface. no result with iwconfig , and no luck with trying aliases.

What I've tried with no success:
-Modifying module blacklists, trying to keep wl from loading
-completely removing wl, and installing b43 revisions.
-based on broadcom & linux kernel docs, broadcom-wl- should work, but it does not.
-no success even with broadcom-wl-
-No success with recompiling broadcom driver from scratch and inserting module.
-No success on trying above tests on a clean Ubuntu Maveric (10.10)
-No success on multiple recent kernel versions
-No success on using pre-compiled ubuntu driverts for installed kernels
-- firmware-b43-lpphy-installer from ubuntu repository seems to be the one, but prior installation it checks the chip version and stop if it`s anything but bcm4312. 4313 is also a LP PHY chip, but is not supported by this package.

**I've another bcm4312 card that works flawlessly in both backtrack and clean Maveric, as it`s picked up by b43 driver, NOT damned wl .

&-} any comments are welcome... !