My host machine is a lenovo thinkpad running ubuntu 10.04 karmic koala and I am attempting to emulate BT4 R1 in virtual box, but I have literally been trying to figure out how to start networking for over 6 hours.. Literally. I'm very frustrated to say the least. Here's the steps/output/settings for some of the things that I've tried for this particular setup. First off, the output of my host machine after running this command to detect my NIC (I think), reads:

sudo lshw -C net
       description: Ethernet interface
       product: 82577LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 06
       serial: f0:de:f1:03:52:ea
       capacity: 1GB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.0.2-k2 firmware=0.12-1 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:33 memory:f2400000-f241ffff memory:f2425000-f2425fff ioport:1820(size=32)
       description: Wireless interface
       product: WiFi Link 6000 Series
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 35
       serial: 00:24:d7:3e:38:78
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn ip= latency=0 multicast=yes wireless=IEEE 802.11abgn
       resources: irq:35 memory:f2000000-f2001fff
  *-network DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: vboxnet0
       serial: 0a:00:27:00:00:00
       capabilities: ethernet physical
       configuration: broadcast=yes multicast=yes
This seemed kind of interesting to me, even though I'm not entirely sure what this output is/means, the "*-network DISABLED" indication right above an entry with the line "logical name: vboxnet" makes me think and wonder..

Virtualbox configurations network-wise looks like this:

Once I boot up and log in as root in BT4 R1, I try to configure networking to work one of several ways.

One way is by running:
/etc/init.d/networking start
But this only results in the browser thinking it can load pages, and taking a while to figure out that it actually can't. Or, I will try to ping google via the cli and it will take a while and not work.

I've also tried to manually set up the eth0 interface with the dchp server by using the following two commands:
ifconfig eth0 up
dhclient eth0
But this just results in the command line trying to ask the DHCP for what it needs and never getting a response, until the command gives up, reporting that it will "sleep" or something similar.

I've also tried to manually assign an IP instead of asking the DHCP server for one. I don't actually want or need to do this, it was just a means to an end to try and get networking up, but its still not working anyways. Here are the commands:
ifconfig eth0 netmask up
route add default gw eth0
I also added a dns server IP to the resolv.conf file in combination with these two commands, and still no luck at at with any tests with wget, ping, or browser tests.

Any/all help is very mch appreciated, and I'm sorry for wasting space on the forum for such a trivial question, but honest to god I'm fed up trying to do it myself, I really need some help.


This thread on the virtualbox forums was kind of helpful, though it just let me know a bunch of people in similar situations were experiencing similar problems, and never presented any solution..