Results 1 to 2 of 2

Thread: Asus F5RL Ati Radeon Xpress 1100 driver problem

  1. #1
    Just burned his ISO
    Join Date
    Jun 2008

    Default Asus F5RL Ati Radeon Xpress 1100 driver problem

    Hi all,
    i hawe a problem to run the driver for my x1100 under Bt4. I hawe done:

    sudo atp-get update (passed on OK)
    sudo atp-get install ati-driver (and here starts the problem)

    It downloads and starts to aplying the package, but it stops on a Error whyle attempting go on whyte fglrx and it looks like this :

    make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
    make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
    make[1]: Leaving directory `/usr/src/linux-source-'
    make: *** [kmod_build] Error 2
    build failed with return value 2
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware accelerated
    OpenGL will not work and 2D graphics will lack performance.

    insmod: error inserting 'fglrx.ko': -1 Invalid module format
    aticonfig: No supported adapters detected
    ln: creating symbolic link `/lib/modules/': No such file or directory

    When i tried to execute /lib/modules/fglrx/build_mod/' it giwes an error:

    AMD kernel module generator version 2.1
    /lib/modules/fglrx/build_mod/ line 368: [: =: unary operator expected
    doing Makefile based build for kernel 2.6.x and higher
    /lib/modules/fglrx/build_mod/ line 407: cd: 2.6.x: No such file or directory
    make: *** No rule to make target `clean'. Stop.
    make: *** No targets specified and no makefile found. Stop.
    build failed with return value 2

    And from the 407´th line seems like this :
    cd 2.6.x

    make clean

    echo 'This is a dummy file created to suppress this warning: could not find /lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC4.cmd for /lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC4' > .lib${MODULE}_ip.a.GCC${GCC_MAJOR}.cmd

    I tried to change it to the actual directory cd /lib/modules/fglrx/build_mod/2.6.x, butt then it wont execute ( bash: /lib/modules/fglrx/build_mod/ permission denied ) and it stil deniing after any change i do to the file.

    I would like to make run my graphic card on Bt4, sience i wont longer use windows systems anymore, but most graphical progs. wont work because of my driwer not properly installed.
    Also i found out, thad the package managers dont support rewritting some files, while their are a part of some other packages and will abort he action afterwards when i tried to get the fglrx run trough another (of course after uninstalling of the previous package and apliing the other, the same problem whyte fglrx appeared).
    If anyone can help me out of this mess, i will be werry greatfull for it.

    P.S.: im using the BT4 final, not the R1 version.

  2. #2
    Good friend of the forums Eatme's Avatar
    Join Date
    Aug 2009

    Default Re: Asus F5RL Ati Radeon Xpress 1100 driver problem

    Last edited by Eatme; 09-14-2010 at 03:00 PM.
    Wiffy-Auto-Cracker - was the best thing that ever happen to me. :) Wo0oT :)
    AWUSO36H_500mW_5dBi Antenna

Similar Threads

  1. ATI Mobility Radeon x1400 driver
    By DarthVega22 in forum Beginners Forum
    Replies: 3
    Last Post: 03-28-2010, 10:13 AM
  2. his radeon hd 4830 resolution problem
    By coronaflyest718 in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 02-26-2010, 07:38 PM
  3. Refresh problem (ati radeon hd 4670)
    By 3katana in forum OLD BackTrack 4 NON working hardware
    Replies: 0
    Last Post: 07-03-2009, 11:02 PM
  4. ASUS 1000HE Intel 945 Graphic driver
    By thugniggahh in forum OLD Bt4beta Non-Working Hardware
    Replies: 1
    Last Post: 06-07-2009, 05:41 PM
  5. Asus N10J-A2 + Ubiquiti SuperRange Xpress
    By seanothan in forum OLD BT4beta Working Hardware
    Replies: 0
    Last Post: 03-27-2009, 03:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts