Great work guy’s script looks good; I can't wait to get mine working.
Using version #102 with atheros wifi on eeepc using BT4-r1

First problem
can't get consistent results using airbase-ng, sometimes XP or Vista won't connect, the next time it connects OK. I have tried changing line 1412 as previous discussions. (Removed -W 0 & -a) in various configurations still same. Tried different environments, distance between machines and the results are never the same. I think some of the better results were in an area where there were NO other AP’s, so I guess it may be interference from other signals.

Second problem
When I do get my client connected firefox gets Server Not Found, and Failed to connect. (It has worked it many, many times in previous versions, even had wkv working but not much success in the last couple of weeks)
Log shows –
Monitoring connections
Connections~watch –d –n 1 “arp –n –v –I at0”
Waiting for target to run “update” file
Started reverse handler on
Starting the payload handler…
Client 00:1A:73:xx:xx:xx associated (unencrypted) to ESSID “Free-WiFi 102”

Tried HostAP but this fails to start. Any pointers to getting hostAP working as I hope this may solve some problems then I can concentrate on the other nice things.
So frustrating as the script now looks awesome and so much work put into it.
Great Work .