I am working through MSFU and am having trouble configuring karmetasploit when installing the sqlite3 ruby. The error message is as follows:

Building native extensions. This could take a while...
ERROR: Error installing sqlite3-ruby:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for sqlite3.h... yes
checking for sqlite3_libversion_number() in -lsqlite3... yes
checking for rb_proc_arity()... no
checking for sqlite3_initialize()... no
sqlite3-ruby only supports sqlite3 versions 3.6.16+, please upgrade!
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.

The sqlite3 version in BT4R2 is 3.5.9. Based upon my review of the same installation error in contexts other than BT4, it appears that upgrading sqlite3 solves the problem.

When I try to upgrade it via apt I receive a notice that the newest version is installed. Is 3.5.9 the latest version in the repositories? Can I upgrade manually without fear of breaking other applications? Or am I totally on the wrong track in trying to get karmetasploit to work in the first case?

(I did notice that I needed to update to RubyGems 1.3.7 to install the activerecord gem)