Results 1 to 1 of 1

Thread: Dradis default install on BT4-R1

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010

    Exclamation Dradis default install on BT4-R1

    Hi, i've got a problem running dradis 2.4.1.
    First i run the /pentest/misc/dradis/ and get this :
    Looking for Ruby interpreter... found [ /usr/bin/ruby ].
    Checking for support to compile native extensions... found.
    Looking for RubyGems and the 'gem' command... found [ /usr/bin/gem ].
    Looking for the 'rake' command... found [ /usr/bin/rake ].
    Looking for SQLite3 libraries... found.
    Looking for the SQLite3 ruby gem [sqlite3-ruby]... NOT found.
    SQLite3 ruby gem (sqlite3-ruby [>= 1.2.4]) not found. Try:
      gem install sqlite3-ruby
    Ok then i run this command and get this :
    ERROR:  Error installing sqlite3-ruby:
            ERROR: Failed to build gem native extension.
    /usr/bin/ruby1.8 extconf.rb
    checking for sqlite3.h... yes
    checking for sqlite3_libversion_number() in -lsqlite3... yes
    checking for rb_proc_arity()... no
    checking for sqlite3_initialize()... no
    sqlite3-ruby only supports sqlite3 versions 3.6.16+, please upgrade!
    Once again ok , i download and install the latest version of sqlite3
    sqlite3 --version
    Then it should be alright but the ruby error persist even using the options proposed --with-sqlite-dir

    Anyway i launch the dradis server and client without sqlite and i get this error when i launch the client ... which seems normal as there is no database :
    event(s) registered: [:exception]
    Registered observers:
    {:exception=>[#<Core::Exceptions::Ui::WxWidgets::DradisGui:0xb4b abee0>]}
    and in the GUI :
    [error] It was not possible to connect to the server using the credentials stored in ./config/dradis.xml.

    Does anyone have an idea or even better : a solution ?
    thanks for your help ! :confused:
    Last edited by Archangel-Amael; 08-31-2010 at 07:19 PM. Reason: fixed code tag and removed smilies from text.

Similar Threads

  1. Dradis Framework and MSF 3.4 trouble
    By EdgesofTwilight in forum Beginners Forum
    Replies: 2
    Last Post: 09-28-2010, 09:14 PM
  2. Dradis 2.5.2 / svn
    By JF1976 in forum Tool Requests
    Replies: 0
    Last Post: 08-19-2010, 11:14 AM
  3. dradis load error
    By Wolfheart in forum OLD Newbie Area
    Replies: 5
    Last Post: 12-05-2009, 05:47 PM
  4. dradis v2.4
    By prowl3r in forum OLD BackTrack 4 Package and feature Requests
    Replies: 0
    Last Post: 10-01-2009, 11:28 PM
  5. MSF dradis
    By ammadeyy in forum OLD Newbie Area
    Replies: 2
    Last Post: 09-24-2009, 09:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts