Results 1 to 5 of 5

Thread: Problems Installing CUDA on BT4 Final

  1. #1
    Just burned his ISO
    Join Date
    Jul 2010

    Default Problems Installing CUDA on BT4 Final

    My System Specifications
    EVGA 790i Ultra Motherboard
    3.0GHz Dual Core Processor (Socket 775)
    (2) EVGA GeForce 8600 GTS GPUs connected with SLI bridge
    BackTrack 4 Final (installed on a partition of my USB HDD using the tool)

    I am trying to implement CUDA into pryit and aircrack-ng, however I am having a few problems. I was following the guide found here,

    First I ran "apt-get update"

    Then hit Ctrl+Alt+Backspace to exit X console. I then ran "apt-get install nvidia-driver"

    After it is done installing the driver I get the message
    "(++) Using config file: "/root/" Number of created screes does not match number of detected devices. Configuration failed."

    I notice that the xorg.conf file also lists 20 some monitors, 30 some devices, and 30 some screens when I only have one monitor and two graphics cards. I try running "nvidia-xconfig" but that does not correct this.

    I can run "apt-get install cuda-toolkit" without a problem.

    I try to run "apt-get install cuda-sdk", but it says the file isn't there. After searching on the forum, I found out this file was removed. However, I am having problems finding the cuda-sdk on the NVIDA website. I can only find the drivers and toolkit. Could someone post a link to the download on the NVIDA website?

    Has anyone else had trouble installing the NVIDIA drivers like I have? I tried installing the newest drivers from the NVIDA website, but I ended up locking myself out of X-server because I keep getting a "Fatal server error: no screens found. giving up" message. Is there anyone to fix this without me uninstalling and reinstalling BackTrack 4 to my USB drive?

  2. #2
    Join Date
    Mar 2007

    Default Re: Problems Installing CUDA on BT4 Final

    The screen error is normal, I always get that.

    The new sdk can be downloaded from here:

    The drivers are for the newest kernel so make sure you have 2.6.34

  3. #3
    Just burned his ISO
    Join Date
    Jul 2010

    Default Re: Problems Installing CUDA on BT4 Final

    Things are getting better, but I'm having problems with pyrit using CUDA now.

    I was able to successfully install the Nvidia driver using apt-get. I then downloaded the latest driver from the Nvidia website, installed it, and everything is still working.

    I downloaded the latest CUDA Toolkit from the Nvidia website and installed that, I didn't use the apt-get command. That seemed to be working.

    UPDATE: I got Pyrit running fine, but I want to build aircrack-ng-cuda, and I need the SDK installed for that. However, when I try to install CUDA SDK it just says "Uncompressing NVIDIA GPU Computing SDK......." then it gives me two blank lines and it will stay like that for hours.

    Did anyone else have problems with this?
    Last edited by JohnDN; 07-17-2010 at 01:36 PM.

  4. #4
    Just burned his ISO
    Join Date
    Jul 2010

    Default Re: Problems Installing CUDA on BT4 Final

    Alright, I solved it. After it gave me the two blinking lines all I had to do was hit enter and it gave me instructions. I got the idea from logging into BT4 thats installed on a hard drive. The password is toor, but it doesnt show up when you type it.

  5. #5
    Just burned his ISO
    Join Date
    Aug 2010

    Default Re: Problems Installing CUDA on BT4 Final

    Nvidia 8400 GS
    BackTrack 4 - R1 - Ubuntu 8.10 (kernel 2.6.34) (hdd install)

    In the above posts, pureh@te mentions the CUDA 3.1 toolkit. On the nvidia page, they seem to delineate between the Ubuntu 8.10 (2.3 toolkit) and 9.10 (3.1 toolkit, 2.3 toolkit) packages. Since the 3.1 toolkit is for Ubuntu 9.10, can I safely use it on my comp with my distro using Ubuntu 8.10? My guess is that since pureh@te wrote the guide and posted the link to 3.1 then it should be g2g but I just wanted to make sure. I have spent about 20hrs so far trying to get CUDA + pyrit working and I know most of my problems are due to being a 'newer' linux user (i have used Ubuntu for about 2 years but they are so GUI based now my bash skills are somewhat lacking) I am however doing my best to ignore all the fancy tools included in backtrack until I get everything up and working and am more comfortable with the 'basics'

    I do all on my penetration testing on my laptop and the only reason I wanted to get this working on my desktop was to be able to utilize my GPU (albeit crappy at the moment) to speed up WPA bruteforce. (disclaimer: I only test on my own personal network)

Similar Threads

  1. pyrit with CUDA support not showing CUDA cores
    By kill_box001 in forum Beginners Forum
    Replies: 7
    Last Post: 08-14-2010, 06:29 PM
  2. Problems while installing BackTrack 4 Final on HDD
    By nunogarcia in forum Beginners Forum
    Replies: 2
    Last Post: 06-11-2010, 10:15 PM
  3. 9400M Navidia Cuda Problems
    By prairie-guy in forum Beginners Forum
    Replies: 0
    Last Post: 02-02-2010, 09:01 AM
  4. Backtrack4-pre final CUDA all in one guide
    By purehate in forum OLD BackTrack 4 Howto
    Replies: 19
    Last Post: 01-23-2010, 11:58 PM
  5. cuda on bt4 final
    By imported_cironte in forum OLD BackTrack 4 Package and feature Requests
    Replies: 0
    Last Post: 09-26-2009, 08:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts