Quote Originally Posted by XC3416 View Post
First of all thank you everyone for your replies! I was trying Archanel's ideas first, and here's what happened.

I am using a SATA hard drive, and I noticed I don't have any jumpers. Then I checked my BIOS settings, and it was on IDE. I changed it to AHCI and made sure Windows still worked with that, and it did. Then I booted up my Backtrack 4 R1 live CD and still NO hard drives were found. I ran the install script a couple of times and it crashed after maybe the 4th time. Here is the error message I got:
We're sorry; the installer crashed. Please file a new bug report at https://launchpad.net/ubuntu/+source/ubiquity/+filebug (do not attach your details to any existing bug) and a developer will attend to the problem as soon as possible. To help the developers understand what went wrong, include the following detail in your bug report, and attach the files /var/log/syslog and /var/log/partman:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/zoommap.py", line 196, in timeout
  File "/usr/lib/ubiquity/ubiquity/zoommap.py", line 391, in blink
    cr = self.window.cairo_create()
Error: NULL pointer
This happened twice. I think I am going to get the latest Ubuntu like someone mentioned and see if it will see my hard drive while I still try some other things to get this to work. I may install Ubuntu too just to see if maybe Backtrack will pick up that partition because it already has Linux on it, just like someone else already mentioned too

If anyone else has any other suggestions, I would be really thankful, and thanks to everyone who has already written back!

Hey everyone,

I know it has been a while, but I thought I should let you all know what I did to get around this problem. After a lot of searching on the internet, I believe that the drivers for my hard drive weren't there.

My solution:

I installed Backtrack4 R1 on a virtual machine using VirtualBox. Then after installing the VirtualBox tools, everything worked well! Everything works perfectly and I am happy =)

If any of you have any questions, feel free to ask me. I would love to help!
Hey from lat few days i am facing quite a lot of problems in installing Backtrack 4 R2.
I am using a live DVD to start the Installation.
I am currently using Win7 which is the primary partition.
Now i cannot see any of my partition during the Installation, i tried cfdisk, which somehow shows the available 3 primary partition (one already reserved for the Win7 OS) and 2 Logical Drives.
Is there any way i can see and mount my partitions to install a fresh copy of BT on a specific Primary Partition.
All the Partitions are in NTFS format, which were resized with the help of a Partitioning software.
I Currently wish to install BT in a resized-through-windows 60 GB partition.

Any help from any one would be much appreciated.