Hopefully you understood most of my problem from the title. BT2b boots and installs fine. BT2final doesn't. I've tried burning at the slowest speed my burner will allow (4x) and checked and rechecked the MD5sum for multiple ISOs. The disk boots on one laptop and not the other. The boot gets as far as loading the linux live scripts, but slows down dramatically when trying to load the data dictionary and completely stops (disk stops spinning) when trying to start usb support. I've noticed in the changelog at v6.0.0 that there's a note about the USB modules taking a long time to load and that it's being done now only if necessary. So my first question is: Is there a way to not load them? I've crawled through the forums and noticed a mention of a "bt nopcmcia" and even a "nousb" command at the boot prompt. However, when I run these, I see no difference in the boot sequence. Maybe creating a new ISO that doesn't have usb support? I know it was possible to do this at some point, but since moving to the new site from the Auditor Collection, I think a lot of that information got lost or deleted and the ability might not even be there anymore. I'm pretty confident that if I can get it to boot without USB support, I can at least do a HDD install and get the right drivers/modules later. Now, all that being said, BT2b installed fine. No sweat, no problems, up and running fairly quickly. I just prefer to have a stable release. I've also put BT2final on my USB drive (can't boot from it on the laptop I want to install it to, no BIOS support). So my second question is: Is there a way to decompress the files from the BT2final install on my USB drive from a BT2b LiveCD boot and overwrite the BT2b HDD install? I really don't need USB support at all, so really my preferred method is #1 and it seems the easiest and likely already accomplished but thanks in advance for any help.

Just for clarification and those following with similar problems I'm trying to install to a Dell C610 and I think the trouble is caused by the Intel 82801 CA/CAM (ICH3) USB controller.