Results 1 to 2 of 2

Thread: Attempting to add new USB data to zd1211rw driver

  1. #1
    Just burned his ISO
    Join Date
    Apr 2007

    Default Attempting to add new USB data to zd1211rw driver


    I am attempting to use my Zyxel G220 stick with the supplied zd1211rw driver. I have figured from reading around that I need to add the vendor and product IDs into the driver and recompile, however this is causing me some grief.

    I have already tried installing and using the community modified vendor driver which works to a point - however it invariably crashes airodump after 1-5 mins so isn't really useable.

    What I have done so far is to edit the zd_usb.c file found in /usr/src/linux/drivers/net/wireless/zd1211rw/ as instructed and added the line:
    { USB_DEVICE(0x0586, 0x3410), .driver_info = DEVICE_ZD1211B}
    to the top of the table.

    (now comes the part where my linux inexperience becomes obvious...)

    I am unable to compile using 'make' in this folder (it says there is nothing to do), but I can do what I assume is a full kernel compile by going up to /usr/src/linux and running 'make' there (this takes ages though, and I'm sure you are able to just compile the one driver somehow). After this has been done I have the file 'zd1211rw.ko' in my zd1211rw directory. If I understood the instructions correctly, I should be able to run

    insmod zd1211rw.ko

    to insert this module into the running kernel, however I get an error message 'This module contains an illegal character' (or something similar - I can't remember exactly) and refuses to do anything.

    So - what is the obvious step that I'm missing???

    Thanks for any help,


  2. #2
    Just burned his ISO
    Join Date
    Apr 2007


    update: problem fixed. I think it wasn't loading all dependant modules.

    For others with this problem:

    In the compiled dir I ran:
    depmod -a
    modprobe zd1211rw
    rmmod zd1211rw.ko (if the old version was loaded)
    insmod zd1211rw.ko

    after that it was a case of dealing with the wireless setup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts