If you try to boot BackTrack on the new MacBook Pro 7.1, the bootloader/boot menu will not be able to recognize the mac's SATA drives because the new mbp has a MCP89 chipset; see, or just google macbook pro 7.1 and the first result will say "linux not allowed?!" or something like that.

Ubuntu has a patched version for download, but as far as I know other linux distros [INCLUDING BACKTRACK] don't have one yet. I am sure that if you know what you're doing and are fairly determined you can fix this yourself, probably in a similar way. But
this is why people have said many many times on these forums that if you want to boot BT on a Mac, do it with VMware.

Just posting this so that others who are new to BT and/or beginners don't have to go through weeks of googling and searching and reburning and downloading and checksumming .iso's, only to discover that Apple has tried to prevent you from running third-party software (& OS's) on its hardware once again.

Admins, plz bump if this is in the wrong place.

(of course I had problems using VMware fusion to begin with on my mac (related to my usb adaptor, made my Mac kernel panic), so that is why I tried to hard boot it, but that is another long complicated story)

Of course it would be great if someone either made a tutorial/how-to on how to tailor BT so that it's compatible, like they did for Ubuntu; but I don't think that will happen because the population of users trying to use BT on a mac without VMware is probably too small to warrant the time it would take to create a compatible version for download. I'm just disappointed after all this work because I've ended up just installing BT components on Ubuntu, but it's not going to be the same

If anyone has constructive advice (i.e. other than "google it"), or good sources/links to point me toward, please let me know.