Results 1 to 4 of 4

Thread: loop when booting

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010

    Default loop when booting

    I was trying to make some changes to my wifi-card by writing:
    # modprobe -r iwl3945
    # modprobe ipwraw

    Then i lost my internet connection.
    I when i tried to restart my computer it said: exeption Emask 0X0 SAct 0x0 SErr 0x0 action 0x0BMDMA stat 0x24
    failed command: READ DMA
    cmd *heck of a lot of numbers*
    res *same here*
    status: { DRDY ERR }
    error: { UNC }

    This goes on and on so I never got any opportunity to write anything or login.
    (I dualbooted it with xp from the from the live cd)

    It there any way i can do "driver recovery" or such from the live cd or get into the folder where the changes where made from the cd and recover them?


  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010

    Default Re: loop when booting

    Start with the forum faq section and work through it. Also what and why are you trying to change on your wifi card?
    Is this card compatible? How long have you worked with Linux?
    To be successful here you should read all of the following.
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Just burned his ISO
    Join Date
    Aug 2010

    Default Re: loop when booting

    I've been using ubuntu for a while but I like backtrack better.
    yeah my card is suppose to be compatible.
    I try to work on the faq to learn it fully but as i tried to configure the card the system broke down so i need to recover it so i can keep using it to learn.
    Hope you get the point
    but still, is there any way to "restore" it or "recover" it so the drivers are default without having to boot it from the drive (since that doesn't work)

  4. #4
    Join Date
    Jan 2010

    Default Re: loop when booting

    This is indicative of a hdd issue. It could be hardware error, software error, dma controller error, hdd controller error, or any other interconnected component. The looping messages you're seeking are kernel printfs. You'll be able to log-in if the system successfully boots; you won't be able see it, however. There's a way to turn this behavior off. When booting in grub, modify the kernel command line arguments as follows:

    1) remove the 'quiet' specifier
    2) where 'quiet' was, replace with 'loglevel=0'
    3) attempt to boot the system (this might never happen if the hdd is b0rk)

    Once it's booted, have a go at diagnosing the problem using the hdd diagnostics utilities (hdparm, fsck, etc.). It may just be a messed up filesystem that can be repaired. Alternately, you might be able to turn off the dma support in the hdd and see if that fixes the error message (use dmesg and tail /var/log/messages to monitor).

    Modprobe _should_ only affect currently running systems. It does not make changes persistent; for that you'll have to edit some initialization configuration files.

Similar Threads

  1. nmap in loop of ping scans
    By okifd in forum OLD Newbie Area
    Replies: 2
    Last Post: 01-16-2010, 05:53 PM
  2. VNC server loop
    By yalkshire in forum OLD Newbie Area
    Replies: 0
    Last Post: 06-30-2008, 03:01 PM
  3. wpa_supplicant reconnects in an infinite loop
    By iostream in forum OLD Newbie Area
    Replies: 1
    Last Post: 02-12-2008, 04:45 PM
  4. ACK loop during first boot up.
    By kelsey in forum OLD Newbie Area
    Replies: 5
    Last Post: 09-03-2007, 10:36 PM
  5. vnc loop
    By treffer in forum OLD BackTrack v2.0 Final
    Replies: 1
    Last Post: 04-28-2007, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts