Results 1 to 1 of 1

Thread: Cannot associate using BCM4318 and 2.6.34

  1. #1
    Just burned his ISO
    Join Date
    Aug 2010

    Default Cannot associate using BCM4318 and 2.6.34

    Managed mode and monitor mode behaved as expected before kernel upgrade etc.

    First I start a session with xterm

    rmmod b43
    modprobe b43

    dmesg shows:

    b43-phy13: Broadcom 4318 WLAN found (core revision 9)
    phy13: Selected rate control algorithm 'minstrel'
    Registered led device: b43-phy13::tx
    Registered led device: b43-phy13::rx
    Registered led device: b43-phy13::radio
    Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
    lspci -nn shows:

    03:07.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
    Then I

    ifconfig wlan0 up

    then dmesg gives:

    b43 ssb0:0: firmware: requesting b43/ucode5.fw
    b43 ssb0:0: firmware: requesting b43/pcm5.fw
    b43 ssb0:0: firmware: requesting b43/b0g0initvals5.fw
    b43 ssb0:0: firmware: requesting b43/b0g0bsinitvals5.fw
    b43-phy13: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    ADDRCONF(NETDEV_UP): wlan0: link is not ready
    I've tried copying the files from /lib/firmware on the latest livecd to /lib/firmware-2.6.34

    After reloading the driver module, and bring the interface up, dmesg reports the same firmware is being used. I haven't checked file sizes of the firmwares to see if they were different, but I assumed that the new kernel would read the firmware from /lib/firmware-2.6.34. I copied the same firmware on the latest livecd in /lib/firmware to /lib/firmware and reloaded the module (b43), brought the device up, and dmesg reported the same firmware.

    I believe I may be doing something wrong here.

    In any case, currently, that is with the 2.6.34 kernel, drivers, and firmware, I am able to use monitor mode and I can inject and retrieve a 104-bit WEP key from my router.

    Currently I can unable to associate with my router(s) using open, WEP, or WPA2

    Using iwconfig accepts the command to associate, reports no error, but running iwconfig wlan1 to check association shows it does not associate successfully.

    Using wicd, and NO epcryption gives "Connection Failed: Unable to get IP address."

    dmesg gives:
    wlan0: direct probe to MY:AP:MAC (try 1)
    wlan0: direct probe to MY:AP:MAC (try 2)
    wlan0: direct probe to MY:AP:MAC (try 3)
    wlan0: direct probe to MY:AP:MAC timed out
    Using WEP or WPA reports "Bad Password" despite meticulously checking and simplifying passwords.

    I've tried upgrading firmware using the guide at hxxp:// . the b43-fwcutter that comes with backtrack is version 11. I've tried 11-5 and version 13. All 3 gives an MD5 failure with the driver available at hxxp://

    I've tried 2 earlier versions of the Broadcom firmware including a 4.150.??? The firmware appears to install correctly (I tried both /lib/firmware and /lib/firmware-2.6.34. After copying the firmware reloading the driver, and turning the device on, dmesg continues to say the device is not ready, and reports the same firmware from 2007.

    I'd be thankful for any guidance from here.
    Last edited by somedude; 08-14-2010 at 11:37 PM. Reason: corrected a dmesg output

Similar Threads

  1. Broadcom bcm4318 (AirForce One 54g) 802.11
    By Ladrack in forum Beginners Forum
    Replies: 0
    Last Post: 08-13-2010, 09:44 AM
  2. Installing BCM4318 drivers in BT3?
    By Julian8 in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-07-2009, 12:06 PM
  3. Compaq nx6115 with Bcm4318
    By kabeza in forum OLD Newbie Area
    Replies: 2
    Last Post: 09-28-2008, 07:11 AM
  4. BCM4318 doesn't work?
    By dakky21 in forum OLD BackTrack v2.0 Final
    Replies: 3
    Last Post: 08-07-2007, 04:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts