Hello all,

I'm on an Inspiron 2200 with Backtrack 4 and a WG511 v1 PCI wireless card.

I tried to get wireless connectivity with the native p54pci driver which set the interface as wlan0, but this didn't work at all. When I ran
it showed no wireless connections.

I decided to switch to the older prism54 driver because that worked for someone else. This set the interface to eth1 and very nearly got me working wireless. I had to unblacklist prism54 and blacklist a few others, and then I ran
rmmod p54pci
modprobe prism54
ifconfig eth1 up
This set the green status light flashing on the wireless card, but only for about 7-8 seconds before it stopped completely. So I ran dmesg to find the problem:
Loaded prism54 driver, version 1.2
prism54 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
eth1: resetting device...
eth1: uploading firmware...
prism54 0000:03:00.0: firmware: requesting isl3890
eth1: firmware version:
eth1: firmware upload complete
eth1: interface reset complete
ADDRCONF(NETDEV_UP): eth1: link is not ready
eth1: timeout waiting for mgmt response 300, triggering device
I can't get around this block as it keeps saying eth1: link is not ready no matter what else I have tried. To boil it down, the problem I am having is that I activate the card and it comes on for 7-8 seconds, but then shuts off.

Does anyone have ideas?