I would like to try installing BT on my existing partition.

I explain :
- I have an ubuntu distro installed and no more room for partitionning.
- I tried BT in a virtualbox but my network wireless card is not recognized.
- If I boot on a burned iso everything is fine but I can't install BT as I have no more free partitions to use.

So I have two choices :
- Adding parameters in my existing grub configuration to boot directly the iso, I've seen some informations about that but nothing very explicit and I'm lacking informations :
* What should be put after kernel parameters ? (from=bt2final.iso ?, etc)
* Where should I put the Iso ? at the root of a partition (ie /home as I have hdd device mounted as /home) ?
- I've tried to mount the livecd in my linux and copy everything in a subdir (/home/iso/bt2final) and I've added this configuration to boot on it :

title Backtrack
root (hd0,6)
kernel /iso/bt2final/boot/vmlinuz vga=0x317 max_loop=255 initrd=/iso/bt2final/boot/initrd.gz init=linuxrc lang=fr load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=100000 root=/dev/ram0 rw
initrd /iso/bt2final/boot/initrd.gz

the root parameter is correctly pointing on my /home partition (btw I'm using XFS) :
# fdisk -l /dev/sda

Disque /dev/sda: 100.0 Go, 100030242816 octets
255 têtes, 63 secteurs/piste, 12161 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 1 192 1536000 27 Inconnu
La partition 1 ne se termine pas sur une frontière de cylindre.
/dev/sda2 * 192 217 206010 83 Linux
/dev/sda4 218 12161 95940180 5 Extended
/dev/sda5 218 472 2048256 82 Linux swap / Solaris
/dev/sda6 473 2384 15358108+ 83 Linux
/dev/sda7 2385 12161 78533721 83 Linux

# mount
/dev/sda6 on / type xfs (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.17-11-generic/volatile type tmpfs (rw)
/dev/sda2 on /boot type ext2 (rw)
/dev/sda7 on /home type xfs (rw)
none on /proc/bus/usb type usbfs (rw,devmode=666)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

#ls -la /home/iso/bt2final
total 8
drwxr-xr-x 4 root root 26 2007-03-13 13:46 .
drwxr-xr-x 4 root root 69 2007-03-13 13:46 ..
drwxr-xr-x 5 root root 4096 2007-03-13 14:04 boot
drwxr-xr-x 8 root root 4096 2007-02-24 18:44 BT

And I can boot on it when I select it from the grub menu.
But in fact I boot the syslinux part but not the live cd, as I get this message :

"Fatal error occured. Livedata not found
Searching for BT directory"

And it stops here

So if someone can help me finding a way to boot like that, using directly the iso or the subdirectory, it would be cool !