hi guys

i'm new to backtrack and i need a little help here with my bluetooth setup. i have setup the bluetooth but bluebugger, l2ping and sdptool browse, all of them give some kind of /dev/rfcomm0 error. im using a usb dongle and been tryin to connect to my nokia 7610. belOw is the code :

mkdir -p 666 /dev/bluetooth/rfcomm
mknod -m 666 /dev/bluetooth/rfcomm/0 c 216 0
mknod --mode=666 /dev/bluetooth/rfcomm0 c 216 0

# setting up hci 

hciconfig -a hci0 up
hciconfig -a hci0 class 0x500204
hciconfig -a hci0 lm master;
hciconfig -a hci0 lp rswitch,hold,sniff,park;
hciconfig -a hci0 noauth
hciconfig -a hci0 name DJ


hcitool scan
Scanning ...
        00:14:A7:77:77:77       dJ Shani

hcitool info 00:14:A7:77:77:77
Requesting information ...
        BD Address:  00:14:A7:77:77:77
        Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00

# Blue-bugger

bluebugger -m Deejay -a 00:14:A7:77:77:77

bluebugger 0.1 ( MaJoMu | www.codito.de )

Target Device:  '00:14:A7:77:77:77'
Target Name:    'dJ Shani'

Cannot open '/dev/rfcomm0': Device or resource busy

# Tried the above command with -c and tried different channels but still i get the same output

# L2ping

l2ping 00:14:A7:77:77:77
Can't connect: Device or resource busy

# sdptool 

sdptool browse
Inquiring ...
Failed to connect to SDP server on 00:14:A7:77:77:77: File descriptor in bad state

# Tried to bind it as shown in the turtorial and then tried to connect but failure

rfcomm bind /dev/bluetooth/rfcomm 00:14:A7:77:77:77 4

rfcomm connect /dev/bluetooth/rfcomm 00:14:A7:77:77:77 4
Can't connect RFCOMM socket: Device or resource busy
i'm using Backtrack 4 final, booting from live USB. i rebooted several times and tried configurations from a few different tutorials but i still get the same error messages. i have already tried restarting my phone many times. Kindly help me out with what im missing here and how can i get over this "Device or resource busy" thing. Thanks alot.