Results 1 to 10 of 11

Thread: X (NVidia) fails after apt-get upgrade

Threaded View

  1. #1
    Senior Member voidnecron's Avatar
    Join Date
    May 2010

    Default X (NVidia) fails after apt-get upgrade


    First of all, I couldn't find anything usefull in the search, but if I've overlooked something, please point it out.

    For some stupid reason I ran apt-get update && apt-get upgrade in a terminal in X.
    Obviously the upgrade couldnt upgrade the nvidia drivers, so I figured it would skip those. Apparently it didn't, and now my driverset seems out of sync with the kernel or something.

    The exact error when X tries to start is:
    FATAL: Module nvidia not found.
    (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check you system's kernel log for additional error messages.
    (EE) Failed to load module "nvidia" (module-specific error, 0)
    (EE) No drivers available.

    I've tried to run apt-get update and upgrade again, but it states there are no new packages.
    What do I need to do to reinstall the nvidia drivers?


    UPDATE: I've just uninstalled the Nvidia package via aptitude, afterwards apt-get dist-upgrade installed some nvidia driver part again. However, the NVidia package isn't listed in aptitude (under BackTrack-GPU).

    X still doesnt start. Different error though:
    (EE) No devices detected.
    Fatal server error:
    no screens found.
    Last edited by voidnecron; 07-23-2010 at 11:34 AM.
    "The difference between RAID1 and RAID0 is that the zero stands for how many files you're gonna have after a harddisk failure."

Similar Threads

  1. APT-GET fails
    By spriggsy in forum Beginners Forum
    Replies: 2
    Last Post: 05-15-2010, 04:27 PM
  2. pyrit CUDA nvidia Tutorial + Nvidia overclock instructions
    By purehate in forum OLD BT4beta HowTo's
    Replies: 155
    Last Post: 01-26-2010, 12:27 AM
  3. Replies: 0
    Last Post: 11-17-2009, 09:08 PM
  4. followed pure h8te's cuda guide -- nvidia driver fails
    By andytof47 in forum OLD Newbie Area
    Replies: 1
    Last Post: 09-23-2009, 01:44 PM
  5. Nvidia driver fails to find the kernel source tree
    By MonkeyPoo in forum OLD BT3beta Software related issues
    Replies: 7
    Last Post: 01-16-2008, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts