Results 1 to 3 of 3

Thread: WUSB54GC not working after dist-upgrade

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Post WUSB54GC not working after dist-upgrade

    Can someone shed some light on this. Has anyone run into this issue.

    Steps i took

    install bt4 final
    apt-get update
    apt-get upgrade
    apt-get dist-upgrade

    After rebooting when I plug the WUSB54GC into a USB port I am unable to start up the wireless card.

    dmesg reports rt73.bin firmware error same a reported by user akegameesou in another forum.

    Any ideas or resolution coming soon.


  2. #2
    Just burned his ISO
    Join Date
    Mar 2009

    Default Re: WUSB54GC not working after dist-upgrade

    I got this problem too

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010


    I have yet had time to do this but it supposed to fix the issues.

    BackTrack ISO Kernel 2.6.34 Upgrade

    I tried the BT 4 dev relese 1 bootble ISO nd my broadcom card 4315 was working but the WUSB54GC card still has the same issues.

    I installed BT4 Dev R1. My Broadcom card works in this kernel for a bit then stops. But I still have issues with the WUSB54GC card. With the Broadcom card in bt4 dev R1 I have reconnect to my wireless AP to get traffic flowing again. It is not my app stopping traffic as I tested my connection via a download from another BT4 install.

    I went back to BT4 Final did the apt-get update and apt-get upgrade and the WUSB54GC card stopped working. The rt73.bin was not in /lib/firmware

    I did some digging and fixed it the WUSB54GC issue in BT4Final with the apt-get update and upgrade after getting the the following errors. The steps to fix this follow.

    root@bt:~# update-rt73-firmware
    --2010-07-29 17:22:06--
    Resolving Ralink corp. | Home...
    Connecting to||:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2010-07-29 17:22:07 ERROR 404: Not Found.

    E: Can't download index page
    E: Please download firmware RT2501USB(RT2571W/RT2671) from
    E: and unpack the rt73.bin file into /etc/firmware.

    -Get the driver from here: Ralink corp.
    -download the zip from "Firmware RT2501USB(RT2571W/RT2671)"
    -extract the rt73.bin file from the zip and move it to the /lib/firmware- directory.
    -unplug and reInsert the to USB and all is good an working.
    Last edited by Archangel-Amael; 08-04-2010 at 03:59 PM.

Similar Threads

  1. Replies: 10
    Last Post: 08-01-2010, 02:39 AM
  2. Linksys WUSB54GC -rt73usb- card not working after dist-upgrade
    By akegameesou in forum Beginners Forum
    Replies: 6
    Last Post: 07-17-2010, 01:25 PM
  3. apt-get dist-upgrade issue
    By RageLtMan in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 13
    Last Post: 01-14-2010, 08:12 PM
  4. dist-upgrade and scapy broken
    By bofh28 in forum OLD BackTrack 4 Software Related Issues
    Replies: 4
    Last Post: 01-11-2010, 11:11 PM
  5. Replies: 0
    Last Post: 11-17-2009, 09:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts