Results 1 to 2 of 2

Thread: Macbook Pro Trackpad/USB Mouse not working after upgrade 2.6.34

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Default Macbook Pro Trackpad/USB Mouse not working after upgrade 2.6.34

    Title mostly says it all. Upgraded to 2.6.34 and it broke the trackpad. USB mouse doesn't work either which was baffling. A USB memory stick works fine so it's not the USB as a whole.

    I am using a Late 2009 Macbook Pro. Before I upgraded everything worked fine. Maybe it's just some drivers I need to install?

    Comments would be appreciated.


  2. #2
    Just burned his ISO
    Join Date
    Jul 2010

    Default Re: Macbook Pro Trackpad/USB Mouse not working after upgrade 2.6.34

    I had the same problem. I run Backtrack 4 in a Parallels VM on an early 2010 macbook. After installing Parallels tools, there are some lines added to xorg.conf as well as some lines already there
    # The mouse device.  The device is normally set to /dev/mouse,
    # which is usually a symbolic link to the real device.
    #   Option "Device"      "/dev/mouse"
       Option "Device"      "/dev/psaux"
    #   Option "Device"      "/dev/ttyS0"
    #   Option "Device"      "/dev/ttyS1"
    I commented out /dev/mouse and enabled /dev/psaux.
    Next, in the same file:

    # Parallels Mouse section
    Section "InputDevice"
            Identifier      "Parallels Mouse"
            Driver  "prlmouse"
            Option  "Device"        "/dev/mouse"
            Option  "Protocol"      "auto"
    Since parallels is looking for /dev/mouse, but this did not exist on my system, I just made a link that pointed to psaux, thusly:

    $ ln /dev/psaux /dev/mouse

    The above two actions may be redundant, but whatever it works now. I got this info from post #7 in this thread:

    macbook pro hd install (multiple os) - Remote Exploit Forums

    I copied the key portion here:
    By default, the generic X mouse driver (mouse) is used. This won’t let you use cool features like two-finger scrolling, two/three-finger taps (right/triple click respectively), etc. So, you need to use the synaptics driver, but this isn’t trivial to do. The appletouch kernel module needs to be loaded before the usbhid module, otherwise the usbhid mode will act as the driver for the trackpad (it is USB after all). To do this, I blacklist both drivers, and load them manually in the order I want. (Please do let me know if there is a better way of ordering the modules):

    /etc/modprobe.d/appletouch: (create)

    blacklist appletouch
    blacklist usbhid

    /etc/modules: (append)

    # appletouch should load before usbhid so it claims the trackpad
    I did this module stuff he mentions here as well, which maybe you should do first and then reload modules (depmod -a). SOrry things are a little out of order. I'm kind of just writing this as I go, and my kid has a fever and it's late yawn

Similar Threads

  1. Mouse stops working after a few minutes.
    By CodeINe in forum Beginners Forum
    Replies: 1
    Last Post: 01-02-2011, 04:28 PM
  2. MacBook5,1 Trackpad not working
    By n0x|2m in forum OLD BackTrack 4 NON working hardware
    Replies: 8
    Last Post: 09-08-2009, 11:47 PM
  3. UniBody MacBook Pro and Wicd upgrade problems
    By PyrO_PrOfessOr in forum OLD BackTrack 4 Software Related Issues
    Replies: 0
    Last Post: 09-02-2009, 02:32 AM
  4. Trackpad isn't working
    By tommie20 in forum OLD BackTrack 4 Working Hardware
    Replies: 5
    Last Post: 08-21-2009, 02:44 AM
  5. Help! PS2 Mouse not working in BT2 Final
    By islanman in forum OLD BackTrack v2.0 Final
    Replies: 1
    Last Post: 03-29-2007, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts