Results 1 to 2 of 2

Thread: WPA2-PSK does not work with Intel 5100 AGN Card.

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Default WPA2-PSK does not work with Intel 5100 AGN Card.

    I used KwifiManager - turned out to be a primitive piece and I beleive does not support WPA2
    tried WiCD and it throws up with too many errors.
    iwlist scan will show networks and I can connect to unsecured ones.

    I tried to put info into the /etc/network/interfaces ( see the # commented info - I used Wext and Iwlang and none of them work )

    Interface Chipset Driver

    wlan0 Intel 4965/5xxx iwlagn - [phy0]
    (monitor mode enabled on mon7)

    Analysis : ( Not sure If I am right - you tell me )
    So airmon tells me that iwlagn is the driver whereas wext is what wpa_supplicant mentions. Now is wext a generic name that will include iwlagn below it or both are at the same level , which means it could be a hopeless excersie getting iwlagn driver run on Intel 51000 agn as this iwlagn is not mentioned in list of drivers supported OR I can hope to get wext running instead of iwlagn and that in turn will work..? If that is the cause- that is if in fact if it is only then - how do I unload iwlagn and load wext .

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet dhcp

    auto eth1
    iface eth1 inet dhcp

    auto eth2
    iface eth2 inet dhcp

    auto ath0
    iface ath0 inet dhcp

    auto wlan0
    iface wlan0 inet dhcp
    # wpa-driver iwlagn /* and yes I tried wext here too. No good. */
    # wpa-ssid biggassbbq1
    # wpa-ap-scan 1
    # wpa-proto RSN
    # wpa-pairwise CCMP
    # wpa-group CCMP
    # wpa-key-mgmt WPA-PSK
    # wpa-psk 0c2895ae8a31a76ef800adcae1f6246a706b412e033efc4948 6647f148fe926a

    wpa_supplicant -d<driver> etc -c<filename>-dd etc command ( run in verbose mode ) output

    Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
    Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
    Line: 4 - start of a new network block
    ssid - hexdump_ascii(len=6):
    7a 73 75 7a 73 61 <SSIDName>
    scan_ssid=1 (0x1)
    proto: 0x3
    key_mgmt: 0x2
    pairwise: 0x10
    group: 0x10
    PSK - hexdump(len=32): [REMOVED]
    Priority group 0
    id=0 ssid='zsuzsa'
    Initializing interface (2) 'wlan0'
    SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
    capabilities: key_mgmt 0xf enc 0xf flags 0x0
    WEXT: Operstate: linkmode=1, operstate=5
    Own MAC address: 00:1e:65:83:7a:4a
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    RSN: flushing PMKID list in the driver
    Setting scan request: 0 sec 100000 usec
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    Using existing control interface directory.
    Added interface wlan0
    root@bt:/# iwpriv wlan0 set Authmode=WPA2PAK
    iwpriv wlan0 set Authmode=WPA2PAK
    wlan0 no private ioctls.

    root@bt:/# . hq mount

    and when I restart /etc/init.d/networking I get wlan0 no DHCP offers received. Sleeping ....

    ANY IDEA folks to get this running
    Thanks many

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010

    Default Re: WPA2-PSK does not work with Intel 5100 AGN Card.

    Well at least you're making an effort. Try Googling some of those wicd errors you are getting to see if you can find a solution that way, and if you want to try a manual configuration of your card try following this guide from the old BackTrack wiki, just use dhclient instead of dhcpcd. Also, if you want to see the lines that will be recognised in the /etc/network/interfaces file try a "man interfaces" at the comment line.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

Similar Threads

  1. Intel Wireless Wi-Fi 5100 Card injection
    By Mirus in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 26
    Last Post: 02-13-2010, 05:18 PM
  2. Intel 5100 seems to work, but doens't
    By Green222 in forum OLD BackTrack 4 General Support
    Replies: 1
    Last Post: 10-17-2009, 12:47 PM
  3. Intel 5100/5300 wifi card supported?
    By Simen236 in forum OLD Newbie Area
    Replies: 3
    Last Post: 09-24-2009, 06:53 PM
  4. Replies: 0
    Last Post: 03-23-2009, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts