I'm new to this forum and I hope this thread is in the right place, otherwise some admin may be so kind moving it to the location where it shoud be

Here is my point:

My intention is running Backtrack 4 in VirtualBox on a Windows Host (Vista x64). I've read that in a VM its only possible to make use of the features of Backtrack by using an USB WLan adapter. So here we go, attached my adapter (Netgear WNDA3100v1 ar9170 chipset).

The Problems that are actually driving me into madness:

I set up the VM and installed BT4 with my USB mounted from the beginning. I was aware that there occur errors without using specific updated drivers. So I checked lsusb, iwconfig, ifconfig and airmon-ng erverything seemed alright (showed ath0), of course I wasn't able to use monitor mode.

By following this How-To


the new drivers were installed (I suppose). After a reboot of BT lsusb was showing, that the adapter is connected but iwconfig, ifconfig and airmon-ng did not list my usb adapter. I have tried starting the network in different ways by start-network and /etc/init.d/networking start. Second showed an error message that no interface could be brought up. A short check with lsmod showed that the ar9170usb drivers were load.

I can't get a clue - tried installation a few times by first not attaching the USB adapter and installing the driver first - but this was not leading to success.

May someone have any hints/ideas for me, or has someone experienced the same problem? I'm not sure thats a problem caused by the drivers, maybe it is an problem of handling USB by VirtualBox.

Thanks in advance