Results 1 to 3 of 3

Thread: Cowpatty, virtual machine, and a dictionary file not being found

  1. #1
    Just burned his ISO
    Join Date
    Apr 2010

    Default Cowpatty, virtual machine, and a dictionary file not being found

    I think this is the correct forum to post this in, from the rules description. Sorry if it isn't.

    Here's the issue. I was playing around with pyrit and cowpatty trying to get WPA dictionary attacks down (never done them before). I made the WPA handshake dump, got the file, and had a dictionary file ready (using that massive one from that is suggested on this forum somewhere). I was running BT4 in VirtualBox, with a compatible USB wifi card (that Alfa one that ends in H).

    The command I ran was:
    pyrit -e PPCLI -f /root/all.lst passthrough | cowpatty -d - -s PPCLI -r /root/dumpfile.cap

    It 'sort of' works, insofar as it goes into it's dictionary runthrough thing, but it just stops, says it was unable to find the password in my dictionary file, and says it tried 0 passwords. Tried it a few more times, and each time zero passwords tried.

    So I ran a different app just to test my dictionary file, and this app says no dictionary file was found in the directory.

    But here's the thing: both the dump and the dictionary file are in the same directory, and cowpatty IS loading the dump (tested this by changing it's directory and getting a dump file error in cowpatty from that).

    I've tried changing the extension from .lst to .txt, but still no luck. I can open the dictionary in a text editor and so it's definitely got the content it needs.

    I've tried changing the directories and paths, and tried removing the dictionary's path altogether from the command, both with no luck.

    I've tried not doing a passthrough and just loading both the dictionary and the cap in cowpatty, but no luck.
    I just don't get why it's not loading my dictionary but it is loading the cap. I've pretty much ruled out a corrupted dictionary by trying to use a couple other dictionary files in it's place.

    Anyone have any insight into what I might be missing here? Am I just making a stupid error in the command line? it looks correct to me, but maybe I'm overlooking something. The only thing I can come up with is that maybe cowpatty doesn't like virtualbox and for some reason can't load a dictionary while being virtualized.

    Any help would be appreciated. Thanks

  2. #2
    Just burned his ISO
    Join Date
    Jul 2010

    Default Re: Cowpatty, virtual machine, and a dictionary file not being found

    there is a rule about a 2 gig file size limit, maybe you should look into that.

    i was suggested this, as i am having the same problem :-P

  3. #3
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010

    Default Re: Cowpatty, virtual machine, and a dictionary file not being found

    Does pyrit work with virtual machines? I don't think it will, since it doesn't have a real gpu to work with. Try doing the same, but booted from a live cd, you can put your dump file on a thumb drive.
    Of course, if you really wanted to have some fun, go to Wal-Mart late at night and ask the greeter if they could help you find trashbags, roll of carpet, rope, quicklime, clorox and a shovel. See if they give you any strange looks. --Streaker69

Similar Threads

  1. Hacking in Virtual machine another virtual maching?
    By alhosany in forum Beginners Forum
    Replies: 5
    Last Post: 05-26-2010, 02:14 PM
  2. BT4-PreFinal as a Virtual Machine
    By Dr_IDE in forum OLD BackTrack 4 Working Hardware
    Replies: 0
    Last Post: 06-24-2009, 08:54 PM
  3. BT 4 Beta Virtual machine
    By music5_5 in forum OLD BT4beta Bugs and Fixes
    Replies: 12
    Last Post: 06-16-2009, 09:30 PM
  4. airolib-ng in a virtual machine
    By jkroeder in forum OLD Newbie Area
    Replies: 7
    Last Post: 07-07-2008, 01:29 PM
  5. Running in Virtual Machine
    By Fishbones in forum OLD BT3beta
    Replies: 0
    Last Post: 05-07-2008, 05:46 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts