I'm trying to install BT4 for dual boot (WinXP now installed in one partition) on a Thinkpad R31 laptop. Since this doesnt have a DVD and is unable to boot from USB sticks, the only option is to do a network boot (?) in order to install BT4.

Anyways, I have setup for a network boot, using Tftpd32 and haneWIN NFS Server on my other computer (WinXP). While the process is slower than hell I've managed to get the laptop to boot the BT promt, where I then type "startx" to get the GUI. To this point it works fine.

I then click on the install.sh on the desktop (I've tried running cmd "ubiquity" too). The installation window appears and I see the text that says I should select the language to use for the installation. Only the Quit button is active and the list-area to the left is blank.
Then it stops, after a minute or two the screen goes black with only the pointer showing (unable to move it). I've left it for something like an hour or two but it seems to have crashed.

I'll try to give you some details, let me know if you need anything else:
IBM Thinkpad R31
PXE server: Tftpd32 3.23
NFS server: haneWIN 1.1.70
tried with mounting BT4 in NFS both from a dir (unpacked the iso) and through Daemon Tools

Tftpd Boot File: pxelinux.0

tftpboot/pxelinux.config/default :
DISPLAY /isolinux.msg
KERNEL bt4/boot/vmlinuz
APPEND initrd=bt4/boot/initrd.gz BOOT=casper boot=casper nopersistent rw quiet vga=0x317 netboot=nfs nfsroot=