The Scenario...

Windows 7 Ultimate 32 bit
Running the Later Ver. of VMWare Player
Back Track 4 Final

USB Device
Ive had the...
Linksys WUSB54GC v3
TP-Link WN321G (default out of the box driver)

But am now using the...
Alfa Awus036h 1000mw w/ the default realtek rtl8187 driver (out of the box)

Frankly I am pretty disappointed with the Alfa. I am located indoors, and all the A.P.'s are located between 300-400 ft away also indoors, (But with concrete in between) with the closest A.P. being about 50ft away.

With the TP-Link I was able to see only 2 A.P.'s While sitting inside, but found if I moved outside I could pick up more A.P.'s (as it should be). I was able to successfully obtain the WEP key & WPA handshake with this card, but unfortunately I found that I had to be really close to the A.P. in order for this to work (Approximately within 25-35ft). Just because an A.P. shows in WICD, or airodump-ng does not mean that you are necessarily close enough for the adapter to work in the case of cracking WEP & WPA. Is this correct?

This is why I purchased the Alfa thinking it would fix my problem. With it, I am definitely able to "see" more A.P.'s, but just because I can see them does not mean I can run tests on them unless they are approximately closer than 50-75 ft away, and this is with me outside with the Alfa antenna pointed at the A.P. located inside.

Like I said I am using the ALFA AWUS36h 1000mw with the stock antenna and the default rtl8187 drivers.

My TX Power = 27
I've tried doing this:
Tutorial: Improve TX power by changing the CRDA Regulatory Domain on Ubuntu
And This:
TUTORIAL: Installing drivers RTL8187, r8187, RT2800usb on UBUNTU
In addtion:
I've also tried using the r8187 drivers (I believe that was the correct driver can't seem to find the post anymore)
and finally, Upgrading the TX power to 30 using the Bolivia Country Code.

I am kinda scared to run the
iwpriv wlan0 highpower 1
Thinking it may burn out my adapter on day 1
Could that possibly help me fix my problem, and achieve my goal?

Could I possibly just be too far away? (although I've read posts saying users were able to inject up to 300 meters away).
Would a stronger Antenna help me out (possibly a 9dBi)?
Anyone who has this issue I believe (Snaylor was one) who has a command to run, or a link that can help would be greatly appreciated. There are a ton of posts out there with mixed answers, and no one seems to have an answer, but I could be wrong