Results 1 to 6 of 6

Thread: Unable to find wireless USB in BT4 VM

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010

    Default Unable to find wireless USB in BT4 VM

    I'm running the BT4 Final Release VMware image on VMPlayer 3.0.1, on an XP host machine - a Vaio laptop. Everything seems to work fine, and I'm able to connect to the internet without my USB wireless dongle, using NAT (sharing the hosts IP address).

    The problems occur when I try to get BT4 to recognise my ASUS WL-167g USB wireless card.

    When I plug in my USB dongle, VMware recognises it, and it appears at the bottom right. I change the VMware settings to Bridged Connection, and click "connect" in VMware. XP makes that little beep, and confirms that my ASUS is safe to remove, etc - but VMware doesn't update. I still have the "connect" option at the bottom. Here sre the outputs of some commands I've tried:

    root@bt:/usr/src/linux# ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device

    root@bt:/usr/src/linux# dhclient eth0
    There is already a pid file /var/run/ with pid 17273
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit DHCP | Internet Systems Consortium

    Listening on LPF/eth0/00:0c:29:d8:d8:f6
    Sending on LPF/eth0/00:0c:29:d8:d8:f6
    Sending on Socket/fallback
    DHCPREQUEST of on eth0 to port 67
    DHCPNAK from
    DHCPDISCOVER on eth0 to port 67 interval 4
    DHCPOFFER of from
    DHCPREQUEST of on eth0 to port 67
    DHCPACK of from
    bound to -- renewal in 768 seconds.
    root@bt:/usr/src/linux# airmon-ng

    Interface Chipset Driver

    I'm also receiving error messages that the connection for ASUS device was unsuccessful, citing error code 4, for which there seems to be little information. Also worth noting could be that in my laptop, I have a USB keyboard, USB mouse and now a USB wireless dongle. That's 3 in total.

    Thanks in advance for any help, and I apologise for my noob questions. I've been googling and searching the forums like mad, and to no avail.

  2. #2
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010

    Default Re: Unable to find wireless USB in BT4 VM

    Why are you changing to bridged mode? That has nothing to do with your usb adapter. What does lsusb show after you plug in and tell vmware to take over the usb wifi adapter?

  3. #3
    Just burned his ISO
    Join Date
    Mar 2010


    Hi Barry,

    Thanks for your response.

    When I plug in my usb adapter, as I say, it shows in the bottom of VMware player. I click connect, and then lsusb gives this result:

    root@bt:/usr/src/linux# lsusb
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    The thing is though, the "connect" option never goes away - I hear the beep, and see the USB device vanish from Device Manager in xp, but it never seems to connect in vmware. The icon remains, and hovering over it displays "asustek 802.11 bg wlan", so it's being recognised in VMware to some extent. Occasionally when I unplug and re-plug it in, I get a pop-up telling me it was unsuccessful, and returns error code 9.

    Further investigation reveals the problem is somewhere other than BT4 - it's in the VMware. After enabling my usb device in VMware, about 2 minutes later I'm given the message

    " The connection for the USB device ASUStek was unsuccessful. The VMWare USB Arbitrator returned error code 4"
    I've tried with my Belkin dongle, and that returns the same error code also. When I enable the usb device in VMware, I hear it disconnect from my host machine, so I don't think the problem lays there.
    Last edited by Archangel-Amael; 03-31-2010 at 09:16 PM.

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010

    Default Re: Unable to find wireless USB in BT4 VM

    Try to find out what that second error above is.
    I have had some long response times from vmware while waiting for it to take over the usb device. But I have not had it fail. This of course is in regards to vmware server, though.

  5. #5
    My life is this forum Barry's Avatar
    Join Date
    Jan 2010

    Default Re: Unable to find wireless USB in BT4 VM

    Yea, that's weird. I've never really used the vmware player on a pc, just fusion on my Macs. Usb take over is almost instant. I'll throw the player on my desktop when I get home and see what happens.

  6. #6
    Just burned his ISO
    Join Date
    Mar 2010


    There's lots of entries online about people struggling to find what error code 4 means. The only information I can find on Error code 4 is here -

    VMware Communities: Can we have a documentation of USB ...

    Error message 4 popsup when the vmusb.sys driver fails to enumerate existing USB-devices.

    To fix it enumerate USB-devices yourself by manually adding missing entries in this key :HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Class{36FC9E60-C465-11CF-8056-444553540000}
    I don't understand this! I can open registry editor, find this key, but don't have a clue how to proceed - assuming this information is correct!

    Well, after a few days of googling and messing around, I've solved my problem - which I'll post in case anyone else is searching for the same solution!

    I downgraded VMplayer to V2.5.3, which would still throw up the same problems. However, when I plugged in my USB storage device, it was recognised. I simply removed it, and plugged in my USB wireless dongle, and it worked!

    Not ideal, but hopefully it can help anyone else with the same problem.

    Last edited by Archangel-Amael; 04-03-2010 at 09:07 AM.

Similar Threads

  1. can not find wireless network
    By lukeey in forum Beginners Forum
    Replies: 3
    Last Post: 04-17-2010, 03:22 PM
  2. AWUS036H - Unable to connect when wifi is below -65dbm
    By Dishwasher in forum Beginners Forum
    Replies: 8
    Last Post: 03-26-2010, 11:38 AM
  3. unable to enumerate USB device on port 2
    By OoZic in forum Beginners Forum
    Replies: 2
    Last Post: 02-11-2010, 05:42 PM
  4. Warning: unable to open an initial console
    By Rupert3k in forum Beginners Forum
    Replies: 0
    Last Post: 01-24-2010, 10:11 AM
  5. Airodump can't find wireless networks
    By NumNutt in forum Beginners Forum
    Replies: 2
    Last Post: 01-21-2010, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts