Results 1 to 2 of 2

Thread: AWUS036H Association Troubles

  1. #1
    Just burned his ISO
    Join Date
    Apr 2010

    Default AWUS036H Association Troubles

    Hi guys, I'm new to the BackTrack community and have a question regarding the ALFA AWUS036H (I'll try to be thorough).
    Please feel free to move the topic if it should have been posted elsewhere.

    Following the recommendations of many posters here, I recently acquired an ALFA AWUS036H (rtl8187 driver) and am trying to break into my (own: I do not condone illegal activity) WEP-enabled router.

    I usually search the web and find answers to my issues (as most information is on Google these days), but I seem to have hit a dead-end and find myself in need of assistance.

    I am running BackTrack 4 final (released 11.01.2010) and issuing the following commands:

    ifconfig wlan0 down
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up
    airodump-ng --channel <X> --bssid <XXXX...> -w <path> wlan0
    aireplay-ng -1 0 -e <XXXX...> -a <XXXX...> -h <XXXX...> wlan0
    Filling in the stuff in <>, naturally.

    However I fail to get the "association succeded :-)" message.
    Sometimes, I'd get DeAuth'ed and I can't seem to understand why.
    (In fact, it loops on:
    Sending Authentication Request
    Authentication successful
    Sending Association Request
    sometimes with [ACK], and sometimes with a "received a deauth packet!")

    The aireplay-ng --test succeeds with 30/30 and I've tried the fake auth at various places around the house, with the same result. I've also disabled MAC filtering and tried variations of the aireplay-ng -1, such as the more detailed -1 attack on the aircrack wiki, and with -x 180 to limit packets, but to no avail.

    The Association Succeeded :-) message has appeared briefly once however, after I macchanged my wlan0 to one of the connected PC's. The #/s rating jumped, and the ARP attack looked like it was working. I wasn't using keep-alive though and eventually got deauthed (at least, I think that was the cause), and using the same mac address spoof failed to associate thereafter (rather, I'd get deauth packets like mad).

    I've read around and some other people have had similar problems, though I couldn't find a clear solution. If the answer to this has been posted elsewhere and I've missed it in my search, could someone please point me to it? Any help is appreciated.

  2. #2
    Junior Member Lucifer's Avatar
    Join Date
    Feb 2010

    Default Re: AWUS036H Association Troubles

    A mac filter is obviously in place, even though you say you've disabled it, I highly doubt it:
    The Association Succeeded :-) message has appeared briefly once however, after I macchanged my wlan0 to one of the connected PC's
    Just change your mac again to one of a connected client, and it should work.
    Also remember to use mon0 (monitor interface) for all your attacks, not wlan0! (unless you're using the r8187 driver)

    good luck,

    Last edited by Lucifer; 04-16-2010 at 03:06 AM.

Similar Threads

  1. Debugging Droid WPA association
    By dcx22 in forum OLD Newbie Area
    Replies: 0
    Last Post: 12-17-2009, 09:34 PM
  2. AP Association problem
    By fujianese in forum OLD Newbie Area
    Replies: 2
    Last Post: 11-21-2009, 04:52 PM
  3. 802.11b, 802.11g e aireplay association
    By B@Rz- in forum Angolo Wireless
    Replies: 4
    Last Post: 06-29-2009, 10:48 AM
  4. Association request
    By psp219 in forum OLD Newbie Area
    Replies: 24
    Last Post: 12-12-2007, 02:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts