Results 1 to 2 of 2

Thread: No ethernet frustrations

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010

    Default No ethernet frustrations

    New to BT, new to linux = bad combo.

    laptop has broadcom netlink bcm57780 etherlink pci controller built in. (confirmed using lspci).

    ifconfig shows no eth0 or eth1. I tried /etc/init.d/networking start and neither come up. i also try ifconfig eth0 up and ifconfig eth1 up and also don't work-- no such device.

    so i figure i didnt have the right driver. go to broadcom, find the driver, package comes back with an rpm package i download. after a while i figure out rpm doesnt work on debian so i run alien to convert the rpm. so i run "sudo alien -k tg3-3.99k-1.src.rpm" and when i do that i get some errors--

    "dpkg-gencontrol: error: current host architecture 'i386' does not appear in package's architecture list (amd64)
    dh_gencontrol: command returned error code 65280
    make: *** [binary-arch] Error 1
    find: 'tg3-3.99k': No such file or directory"

    now I am at a bit of a loss for moving this forward. would really appreciate some sage advice on what to try next.

  2. #2
    Just burned his ISO
    Join Date
    Feb 2010


    Well, at least I am getting somewhere with this...

    So I got directed to this site:

    which detailed my problem. I went through the steps I needed to fix it and when i rebooted, I got a new error in the boot load-- "tg3: problem fetching invariants of chip, aborting"

    by the looks of it that problem may be related to the kernel BT4 is running on--

    I saw some discussion about upgrading the kernel, but didnt see how to
    1. check which kernel my BT4 Final install is running and
    2. upgrade it to something above 2.6.31, which it sounds like fixes things.

    I noticed someone asked that same question in another forum:

    so i am thinking the kernel I have is still 2.6.30 and therefore wouldn't have the fix I need in it. does anyone know if the kernel has been updated yet and how i can tell what kernel i am running?

    the upside is that i am learning alot of linux, just not a lot of backtrack yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts