Results 1 to 2 of 2

Thread: metasploit meterpreter registry space problem

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Exclamation metasploit meterpreter registry space problem

    So I've played around with metasploit for a while now, pentesting my own network. One problem: Once I have successfully gotten a meterpreter shell, I cannot figure out how to correctly modify/add a registry value with a space in the path.

    for example, if I run this:
    HKLM\\Software\\Microsoft\\Windows NT\\CurrentVersion\\Winlogon\\SpecialAccounts\\Use rList -v fred -d 0
    it tries to do something with:

    I have tried to enclose it it quotes, like you would in a windows command shell, and several other things to no avail.

    Any help would be much appreciated.
    (Unfortunatly, I am running metasploit under windows, so could this cause slight syntax problems?)

  2. #2
    Just burned his ISO
    Join Date
    Jan 2010

    Default nvm figured it out.

    figured it out.
    you have to enclose just the part with the space in quotes:

    reg setval -k HKLM\\Software\\Microsoft\\"Windows NT"\\CurrentVersion\\Winlogon\\SpecialAccounts\\us erlist -v fred -d 0 -t REG_DWORD

    also, you have to set a type, such as REG_DWORD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts