I recently downloaded BackTrack 4 and have run into a problem.

My linux experience is limited and I'm only just starting to get a hang of using the console/UNIX commands ect. Before anyone jumps on me for asking to be spoon fed I'm searching for answers while I'm waiting for replies.

So, I downloaded BT4, and played with it as a Live USB (4gb), seemed nice enough and had a bunch of cool tools but i wanted to be able to save files and changes so i decided to buy a 16gb flash drive and install it onto that. I booted BT4 from a DVD and went through the install process, making sure that I installed it to the USB drive (sdb) however i think i forgot to click on the "Advanced" tab on the 7th and final step to change the boot loader from the default hd0 (i think?) to sdb, After BT4 finished installing I clicked to reboot, entered the BIOS and changed the boot from CD/DVD to USB, rebooted and got a boot error from the USB.

Realizing what must be causing the problem I booted from the DVD again, reformatted the USB drive and went through the install process again, this time making sure I set it to install the boot loader to sdb. Once it finished installing I rebooted, set the BIOS to boot from USB, and BT4 booted fine, i made a file and rebooted again just to make sure it was saving files and then shut down. Everything is roses right?

Well not quite, I removed the USB stick and tried to boot windows XP which is installed on my HDD and i got this error:
GRUB Loading Stage 1.5.

GRUB loading please wait...
Error 21
This is no doubt caused from the first install where it installed the boot loader to hd0. Now i can't boot windows. I tried using the XP setup disk to repair the installation but that didn't work. How can i fix this?