Results 1 to 3 of 3

Thread: RTL8180 and ALFA AWUS050NH on Backtrack 4 Final

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Default RTL8180 and ALFA AWUS050NH on Backtrack 4 Final


    I just downloaded Backtrack 4 final and made hdd install. I just completely trusted Backtrack team so i didnt try injection capabilities of my wifi cards (ALFA AWUS050NH and netbook's default rtl8180 chipset card). I managed to patch Alfa and work it under backtrack 4 prefinal. Rtl8180 could connect to internet and goes into monitor mode but couldn't search AP's (when execute airodump-ng it searches but finds nothing) on both final and prefinal.On final, Backtrack sees this card as "rtl8180/rtl8185" chipset and "r8180" driver (with airmon-ng command). Apart from that, under final, Alfa couldn't be detected by backtrack at all ( airmon-ng shows nothing, but iwconfig shows just a "ra0" interface). I searched the google but i couldn't find anything since its a new operating system. My questions are :
    1- How could we get Alfa working? I suppose this is a patch issue.
    2- I heard rtl8180 chipsets could be patched. So i tried aircrack's R8180-sa2400 patch ( but i couldn't even remove r8180 module (error : module doesn't exist in proc/modules). What's the problem. Should i try rtl8185 drivers?

    Footnote: Under prefinal, Alfa could be seen as rtl2500 chipset, but under final, it couldn't be seen at all. How could this happen? isn't Backtrack Final a newer OS?

  2. #2
    Senior Member
    Join Date
    Aug 2007


    1) You will most likely need to do the same sort of patching for awus050nh as I presume there's no rt2870usb driver available for that kernel.

    2) The patch that you applied doesn't apply to the driver in question. rtl8180 I presume would already be using mac80211 based framework. Whilst the r8180 depends on the deprecated ieee80211 framework (and most likely a custom one).

    It would help if you could provide information about your rtl8180 chipset, such as a lspci -nnk output and maybe a complete dmesg dump.

    Footnote: There is a mistake with the detection mechanism, I personally have not tried final yet but I'm presuming airmon-ng under final (which is actually part of aircrack-ng suite) is updated. rt2500 is a series of chipsets developed by ralink which aren't 802.11n capable. Your awus050nh would be at minimum rt2870 based which are 802.11n capable.

  3. #3
    Just burned his ISO
    Join Date
    Jan 2010



    Sorry about for this late answer. I was trying to get this both cards working under same OS. I did troubleshoot all of my problems that i encountered but i have still questions.
    As you recommended lspci -nnk query, i found out my default wifi's chipset correctly (rtl8187SE). The only guide for this chipset was in here ( It was for BT4 Beta. So i needed a patch for Alfa AWUS050NH that works under BT4 Beta and i found in here (
    The problem was BT4 Beta had no installer and i had to do manuel hdd install from usb so i tried this (
    I had Winxp and BT4 Final with grub before. So in a live session i destroyed BT4 final partitions, created new ones and started to manuel install.I copied files with no problems.But i have encountered "command not found" error when i tried to install grub "installpkg /mnt/sdc1/grub-0.97-i486-6.tgz". Yes, i noticed sdc1 interface was my usb interface so i changed it to correct letters (sdb). And yes, i put grub-0.97-i486-6.tgz file in my usb thumb. But still i couldnt install grub and couldnt reach both windows and BT4 Beta. So i solved this problem my installing Ubuntu 9.10 which installs grub automatically.
    1. Where could i find a GUI based Grub installer?
    I managed to work both rtl8187se with Coffee driver and rt2870 with Apocolipse driver. Coffee driver is a very basic driver. You can see that while you try to put that card into monitor mode. In short words, it works very slowly when i tried Chop-Chop method and sometimes it cannot do fake authentication. (instability, i think).
    2. Is there any better drivers for rtl8187se?
    Apocolipse drivers working just fine with a small problem. When i try fake authentication with fake MAC address of my wifi card, the packet which i forged by the methods of chop-chop, doesn't generate any data traffic (IVs). So i have to use my real MAC address in order to get results from Chop-Chop. It situation is exactly the same in BT3 for this card (AWUS050NH). I didn't encountered this problem for rtl8187se card under coffee drivers.
    3. So how could we solve this issue?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts