Results 1 to 2 of 2

Thread: RA73 WUSB54GC USB Driver in VMware

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010

    Default RA73 WUSB54GC USB Driver in VMware

    I downloaded the BT4 Final release VM image and am trying to get my wireless USB dongle to detect but nothing is showing up. It is a Linksys WUSB54GCv3 which from everything i've read should work with the RA73 drivers.

    The interface will not show up. If i look in System>Settings>Hardware>USB i can see under EHCI Host Controller a 802.11 g WLAN with the Manufacture Ralink.

    Yes i have this attached to the VM. I also tried to update the driver using serialmonkey's, as per this thread:

    The driver install works fine: modinfo rt73 lists the new driver output. (I'm using version 3.0.3)

    As a last resort i tried to use the .ISO version of BT4Final and boot with the usb plugged in, same results.

    How can i tell if a driver is failing to apply to this adapter or does anyone else have an idea?

    Positive feedback is appreciated, i'm not a total newbie


  2. #2
    Senior Member
    Join Date
    Aug 2007


    There are lots of thread about this dongle. Truth be told that it isn't a rt73 or rt2570 chipset but rather a rt2870 based chipset. You can try the rt28xx driver that's available in the repo.

    Even if the chipset is actually a rt73, there has never been the need to install any separate drivers for it as it would have been included in backtrack since backtrack2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts