Results 1 to 3 of 3

Thread: wirelesss network card - NO power

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010

    Default wirelesss network card - NO power

    Hello, I've played with linux on and off for the last few years but have always had issues getting my wireless network cards to work. I decided to come back to linux a few years later in the hopes that this process would be easier. Alas, it seems to be the same issue. I have a laptop with a build in wireless card (Atheros comm AR5001 wireless network adapter - AS ID'd by Backtrack). However, when I try to use it..or access my network use the wireless adapter I have noticed the 'power' button on the laptop is still red (indicating NO power to the wireless card). When I boot back to windows I must push the power button to turn the wireless card back on. This does NOT work thru backtrac (or linux for that matter). I figure there is a script or command that I must type to turn the power on. That being said, I've used the following commands thru the consol:

    root@bt:~# iwconfig wlan0
    wlan0 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    AND SINCE i've seen the request for this before I'm including a lspci -v command:
    07:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
    Subsystem: Hewlett-Packard Company Device 137a
    Flags: bus master, fast devsel, latency 0, IRQ 23
    Memory at c2000000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [40] Power Management version 2
    Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
    Capabilities: [60] Express Legacy Endpoint, MSI 00
    Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
    Capabilities: [100] Advanced Error Reporting <?>
    Capabilities: [140] Virtual Channel <?>
    Kernel driver in use: ath5k
    Kernel modules: ath_pci, ath5k

    I've also tried:
    root@bt:~# /usr/bin/start network
    bash: /usr/bin/start: No such file or directory

    I've tried this:
    root@bt:~# /etc/init.d/wicd start
    Starting Network connection manager: wicd.

    But from here I do not know where to go? No window comes up? And still thru this the whole thing the 'power' button on my laptop does NOT change from red to blue (indicating power to the wireless card). The laptop still looks and acts as if the wireless card does NOT have power. All I want to do is turn the power on to the wireless card. I feel that if I can figure that out I can then get the rest of the network issues resolved. I'm currently connected to this site using the wired connection to my laptop...but I got this distro for the wireless tools associated.

    Any help that ANYONE may have I would very much appreciate. Thanks!

  2. #2
    Join Date
    Jan 2010
    Helsinki, Finland

    Default Re: wirelesss network card - NO power

    Hi first start networking
    /etc/init.d/networking start
    then start wicd form K-menu|internet|wicd
    then you can open wicd from link next to clock.

    Once you got wicd working you want to log off. (ctrl+alt+del)
    You want to do this, cause all programs that are open when you log off will start every time when you start BT4

    I think that BT4 will recognize that wlan device as wlan0 then you can try to
    ifconfig wlan0 up

  3. #3
    Just burned his ISO
    Join Date
    Mar 2010

    Default Re: wirelesss network card - NO power

    first thing to do, yes type in /etc/init.d/wicd start at the terminal either before u type startx or when u had log in as root..

    after that just iwconfig to see ur intrface..

    see to the ESSID: if "" still blank and Access Point: Not-Associated, u can just pick any wireless connection in wicd..

    if u cant make connection, type in the terminal
    PHP Code:
    ifconfig wlan0 down 
    and then retry the connection..

Similar Threads

  1. Replies: 6
    Last Post: 05-22-2010, 12:01 AM
  2. Can someone help me with my network card?
    By tiger33 in forum Beginners Forum
    Replies: 9
    Last Post: 03-20-2010, 05:39 PM
    By moorejohn90 in forum Beginners Forum
    Replies: 2
    Last Post: 03-16-2010, 04:03 AM
  4. Is my network card compatible?
    By Kaotik in forum Beginners Forum
    Replies: 4
    Last Post: 02-14-2010, 07:04 AM
    By a608863a in forum Beginners Forum
    Replies: 2
    Last Post: 02-14-2010, 02:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts