Hy there,
first of all I'm not the super LINUX-crack (so it may be a stupid little mistake) but I searched the forums and didn't find an apropiate solution.

So today I just made myself a Backtrack 4 pre-final persistent USB-stick. Everything working fine. I used the package manager to update all packages (apt-get update && apt-get upgrade didn't update some packages) so everything was upt o date. But the Kernel wasn't so I searched and found the news and the commands here.

But when I ran
apt-get install -d linux-image
it downloaded Kernel version so I though well no problem (at least I hoped so) and just ran
dpkg -i –force all linux-image-

all working fine (despite a blue screen telling me that there is already some kernel in lib/modules/ or something like that with (maybe due to my previous updates) I just created an old kernel directory) but when I ran
apt-get dist-upgrade
it didn't do anything.. so to say no packages upgraded, updated downloaded or whatever...

and after reboot it still uname -r still shows the old kernel version (I didn't expect it to work anyway)

Could anyone please help me and point out what went wrong?

Regards and thanks in advance!