I have learnt about Metasploit recently through their website and on this forum. I have read loads of documentation but I can’t find out why the exploits won’t work...well to be more exact it looks like it is running the exploit but not executing the payload. I am not using my own exploits; I am using the built ones. Here is an example:
I run Metapsploit on my Back Track 4 live DVD.
The exploits I have used are the ones that are apparently still vulnerable like browser ones.
I used:
as well as other universal ones.

I have now resorted to the absolute basics just to test whether it is successful. With each different exploit I try I choose to deliver the payload “windows/exec”. The command I choose to execute is just a simple IPconfig to a text file and drop it in the C drive on the target PC (ipconfig > c:\meta.txt).
These exploits all exploit the browser so it sets up a fake http service which I then connect to using different browsers from the target machine. As soon as the target machine connects I see a message from the metasploit console (or metasploit gui) saying it is sending the exploit to the machine. From what I understand this means the exploit is actually working but not delivering the payload?
Some info about the target machine:
XP Pro SP3
Windows firewall disabled.
NOD32 anti virus but this is disabled for testing (when it was enabled it detected every exploit attempt).

No matter what payload I run it never works. There is no text file on the C drive.
Maybe these exploits don’t work anymore but I thought that if the console says it has sent the exploit then it does work?
Can anyone help please and point me in the right direction.
I am wondering whether there is something obvious I have missed.