hi to all!
i have backtrack 3 i run it on LIVECD,i have bought TP-LINK321G
when i run airdump there is no AP detected
yes i saw a thread from wiki about updating the driver and i tryed but something is wrong... here the instructions

Download the latest driver from hxxp://homepages.tu-darmstadt.de/~p_larbig/wlan/]ASPj's WiFi Page: mdk3, rt73, rt2570 and other aircrack-ng experiments
As of 2009-04-16, the latest driver is 3.0.2

ifconfig rausb0 down
airdriver-ng remove 31
tar xvjf rt73-k2wrlz-3.0.2.tar.bz2
cd rt73*/Module
make install
modprobe rt73
ifconfig rausb0 up

i downloaded it,and have put the driver on desktop
then i typed---->>> cd Desktop

then i press "tar xvjf rt73-k2wrlz-3.0.2.tar.bz2" -->Cannot open No such file i tryed r xvjf rt73-k2wrlz-3.0.2.tar it opens it BUT! then i type
cd rt73*/Module
and when i press MAKE ----->>no such file...stop...rt73.ko failed to build

also in instructions(from readme) they give this: tar -xvzf rt73-cvs-daily.tar.gz ---> ALSO DOESNT WORK
what to do?