Results 1 to 2 of 2

Thread: [BT3] Problems concerning the xwindow system

  1. #1
    Just burned his ISO
    Join Date
    Nov 2009

    Default [BT3] Problems concerning the xwindow system

    A few weeks ago, I installed BackTrack 3 on my HDD.
    I started to learn Linux commands and as my 2nd OS I chose BackTrack, because a lot of programs, mainly security tools , are pre-installed.

    Still, I have a problem: Until now, I was only able to start the grafical environment by booting from the live CD and choosing the 3rd option (Graphics, VESA-KDE). The first option (KDE) as well as the second one (Flux) failed and I was redirected to the shell.

    The main reason for the HDD install was the fact that I do not have the live CD always with me and I also wanted to store changes on my disk. But when booting via boot-loader, I don't have the choice between grafical and command line mode, so I have to start the xwindow system from the shell. In general, I prefer the shell, but nevertheless, I'd like to know how to start the grafical environment.

    I tried to autoconfigure x (xconf), then started x (startx). The screen went black, the cursor appeared for a few seconds, but then the process aborted and I got this error message:
    [... ]
    (II) Module already built-in
    (EE) AIGLX: Screen 0 is not DRI capable
    xset: bad font path element (#62), possible causes are:
    Directory does not exist or has wrong permissions
    Directory missing fonts.dir
    Incorrect font server address or syntax
    startkde: Starting up...
    DCOP aborting call from 'anonymous-4142' to 'kded'
    kded: ERROR: Communication problem with kded, it probably crashed.
    startkde: Shutting down...
    klauncher: Exiting on signal 1
    startkde: Running shutdown scripts...
    startkde: Done

    I don't know what program interferes the start, so I used xorgconfig and xorgcfg to recreate the conf file, but it didn't work.
    Then I tried to change the x-window manager with xwmconfig, still no success. I also found a parameter called "-forcevesa" or "-forcekde" for startx, but it didn't help in any way.
    My Samsung R610 has a Nvidia GeForce 9200GS grafics chip with 512MB inside, my native resolution (at Windows) is 1366x768px.

    It'd be nice if somebody could help me to solve this problem, by posting ideas or solutions. There also may be a previous post somewhere how to fix the problem. In that case, I'd be glad to get the hyperlink.
    I hope, my English isn't too bad , in German I surely can describe my problem more comprehensively.


  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010


    Quote Originally Posted by JediForces View Post
    I hope, my English isn't too bad , in German I surely can describe my problem more comprehensively.
    Actually Jan your English is better than some native speakers that have posted here.
    However (and I don't know how you missed it) we have a German Community here as well, and a lot of our German members do participate in both English and German.
    To be successful here you should read all of the following.
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts