I recently got a alpha 400 netbook and upgrade the default os to "3xm".
the os comes wit the aircrack-ng tools , how ever it does not recognize my netgear wg111v2 usb card nor will the internal centrino chips set (ipw3945) work when i run airodump-ng it returns

ARP linktype is set to 1 (ethernet) . expected ARPHRD_IEEE80211
or ARPHRD_IEEE80211_prism instead. Make sure RFMON is enabled:
run 'ifconfig eth1 up; iwconfig eth1 mode monitor channel <#>"
When i try iwconfig it says my centrino card is put into monitor mode, but still returns the same message when i run airodump again.

As far as i can tell the centrino set is supported with bt4, and i know the netgear is.

I have looked on many other sites and the most information i can find is that people have gotten it to work but nothing detailing how they did so.My netgear card shows up when i enter lsusb but its not recognized any where else.

If any one has experience with the alpha your advise would be a big help.
Thank you in advance.