Results 1 to 4 of 4

Thread: Possible solution for broadcom-sta [BCM4312 BG] fail?

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008

    Default Possible solution for broadcom-sta [BCM4312 BG] fail?

    Been working on this damn problem about 3 hours and still no result!

    HP mini 2140, BCM4312 b/g rev 01 , kernel

    I guess I've checked almost all google results related to this case. To quickly note the problem I should say that for some unknown reason b43 driver (loaded as b43-pci-bridge)is forcefully loaded, even after cleanly installing 'wl'.
    Do not mention blacklisting tips nor re-compile/installing wl since I've tried every possible situation.
    Now I`ve came to this point that, at least in BT4, blacklisting the b43 is NOT applied. I've tried multiple blacklist file names ( /etc/modprobe.d/blacklist OR blacklist.conf OR blacklist-bcm43)
    ,trying to blocking bcm43xx/ssb/b43/b44/ndiswrapper/b43legacy with no luck. still :
    description: Network controller
    product: BCM4312 802.11b/g
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:08:00.0
    version: 01
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=b43-pci-bridge latency=0
    dmseg have no usefull information :
    dmesg |grep -e wl -e b43
    b43-pci-bridge 0000:08:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    b43-pci-bridge 0000:08:00.0: setting latency timer to 64
    wl: module license 'unspecified' taints kernel.
    Recompiling & building fresh kernel-headers from scratch, followed by compiling wl driver from source and inserting the new module to kernel looks working fine, but no success loading wl at end.

    After removing all b43 & other blacklisted modules and even renaming related .ko files , b43-pci-bridge still loads from no-where and catch the hardware before wl loads. fail again

    depmod, depmod -a & depmod 2,6,30.7 or 'update-initramfs -v -u all' has been tried after replacing and removing drivers. fail again

    what make this harwdare non-working :
    b43-pci-bridge is always loaded BEFORE wl get the chance to catch hardware, so, it fails and you won`t have it working. While card hardware is known by lshw, it`s not detected by driver, so no interface is created.

    possible solution:{you tell me!}
    please show me how to completely get rid of b43 and won`t have it automatically loaded, considering all of my non-working efforts to blacklist it (and other broken drivers)...
    blocking b43-pci-bridge will let wl take control of the card, and it would hopefully work.

    Thanks God that I've my Ubiquity card and not locked down by this problem hardly.

  2. #2
    Senior Member
    Join Date
    Aug 2007


    Read this

    And I would not remove b43 in favour of wl. wl has no support for monitor and injection because broadcrap removed such functionalities under their proprietary linux driver.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2009

    Default Broadcom 802.11g Network Adapter / Broadcom NetLink (TM) Gigabit Ethernet

    I have a problem
    Black Track 4 not recognize my network adapter (Broadcom 802.11g Network Adapter / Broadcom NetLink (TM) Gigabit Ethernet)

    Broadcom 802.11g Network Adapte

    Propriedades do adaptador de Rede:
    Adaptador de Rede Broadcom 802.11g Network Adapter
    Tipo de interface Desconhecido
    Endereço do hardware 00-1F-E2-AB-26-A5
    Nome da conexão Ligação de rede sem fios
    MTU 1500 bytes

    Broadcom NetLink (TM) Gigabit Ethernet

    Propriedades do adaptador de Rede:
    Adaptador de Rede Broadcom NetLink (TM) Gigabit Ethernet
    Tipo de interface Gigabit Ethernet
    Endereço do hardware 00-1D-72-34-C2-3B
    Nome da conexão Ligação de Área Local
    MTU 1500 bytes

    What can I do? Thanks

  4. #4
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010


    Quote Originally Posted by bolaxad View Post
    I have a problem
    Black Track 4 not recognize my network adapter (Broadcom 802.11g Network Adapter / Broadcom NetLink (TM) Gigabit Ethernet)
    Are your cards the same as the one in this thread?
    As for the language, I am not sure if anyone will be able to help you since it is not English. Is it possible to translate it? That might help us to help you.
    To be successful here you should read all of the following.
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts