Hi all

I have just installed BT4 pre final to my primary HDD with XP on it as shown here:

www [DOT] offensive-security [DOT] com/blog/backtrack/backtrack-4-dual-boot-install

I defragged then followed this video exactly. When I restarted my computer after the backtrack installation was complete, I took the DVD out and my computer booted into windows.

Strange I thought, as I expected backtrack/grub to start. During Windows booting, I got the "one of your disks needs to be checked for consistency" message. I skipped this then in windows it 'found new hardware'. The second partition maybe? Anyway...

I realized I needed to change grub to give me boot options on startup so I fired backtrack up from the DVD again and followed the last bit from:

forums.remote-exploit [DOT] org/backtrack-4-howto/23753-how-install-bt4-dualboot-xp-your-hdd-without-vmware-dvd-disk.html

" sudo grub


find /boot/grub/stage1

-- you will know get info about where BT is installed something like (hd?,?) mine was (hd1,1)

then type

root (hd1,1) "

With that done I tried again but it booted into windows. I did more research and found that I needed to type 'setup (hd1)' after the above commands so I did this and was able to boot into backtrack from my HDD and completed the steps from the video tutorial above.

Brilliant, except now when I try and boot into Windows I get: "NTLDR is missing - Press Ctrl+Alt+Del to restart". After lots more research I tried changing around my /boot/grub/menu.lst file without luck. Other forum posts I've found with the same problem talk about rebuilding the windows boot section. I don't think I need to do this as I can access the windows partition from backtrack and all original files seem untouched.

It seems like I'm missing something obvious.

Any help would be greatly appreciated!