The n3 is stil very far from being plug and play with any Linux I've tried so far. when using ubuntu 9.04 the adapter is plug and play with no support for injection.

First I tried the Apocalypse drivers and with it I could get airodump to see only channel 6. This was on backtrack 4 pre final. I was then referred to the aircrack forum. They linked me to (could not post link, but if you google aircrack and look at the one marked tutorial you will find it. or search aircrack n3 and you will find my post and follow the first link.)
the tutorial is a great one for the new Alfa or the 36 Alfa and is for Ubuntu 9.04. I did a clean install of Ubuntu and followed this tutorial and was able to get the rt2800usb drivers to show in airmon for wlan1. Nothing shows in the network manager or Raylink's utility. airodump wouldn't show anything. Kismet wouldn't show anything.

I hear of people saying they have more luck with the 2870 chipset using backtrack 4 beta or bt3 and I hear that it works flawless in backtrack 2 with Hirte drivers. I'll look into that today and report back how that works. As far as bt4 pre release goes, it's a no go.