Hello, everybody!
I just installed Bactrack 4 on a USB drive. Had a little problem with GRUB, which I accidentaly installed on one of the hard drives so I couldn't start my PC without the USB. Eventually fixed it with super grub disk.

But now I have a different problem. Everything works completely fine when I boot up from the DVD I burned, but when I boot from the USB, I have completely no devices mounted. In /mnt/ I have only /usb/ which is empty. I have to 250gb SATA disks, each with 2 partitions and I naturally have the USB disk plugged in I booted from, with two partitions too. But none of them are mounted.
I tried mounting them manually in the usual way -
cd /mnt/
mkdir /mnt/sda1
mount /mnt/sda1 /dev/sda1

I get the error that this device is not a block device.
I tried to substitute sda1 with sda, sda1, sdb, sdb1, sdb2, sdc, sdc1, sdc2 - all with no success.
After hours of trying to find anything similar in this and other fourms, I found nothing.
I will apreciate any suggestions.