I'm a pretty new to linux, but I'm trying my best. I was using the BT4 Beta Live CD to start learning and using the OS, and every time I logged in I got an error, "No screens found" after typing "startx." I read somewhere to type "fixvesa" and then "startx" and that seemed to work and allow me to boot fine.

I just "installed" BT4 onto a free partition, and on boot after logging in and typing "startx" I get the same/similar error:

(==) Log file: "/var/log/Xorg.0.log", Time: Sun Sep 27 17:07:49 2009
(==) Using config file: "/etc/X11/Xorg.conf"
(EE) NV(0): Failed to determine the amount of available video memory
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
giving up.
xinit:   Connection refused (errno 111): unable to connect to X server
xint:   No such process (errno 3): Server error

Of course I've tried doing the regular, "fixvesa" that normally worked on the live cd boot, but I get this error:

[*] Copying /etc/X11/xorg.conf-vesa to /etc/X11/xorg.conf
cp: cannot create regular file '/etc/X11/xorg.conf': Permission denied
Anyway, now I'm confused as to how to boot. As far as I can tell it has something to do with the video drivers? Can somebody please refer me to reading material that will assist me with this problem?

Thank you for your help.