Hi guys, sorry for my poor english. I have a problem: i can't set up wireless interface with faked mac-adress in managed mode. You can see kinda technichal destription below and if u have not enough info i'll post any outputs u need. And a few words more. As u c below, airmon-ng successfully sets up an interface with needed mac, but only in monitor mode, wich i can't change to another one, on the other side if i'm trying to create an interface with wlanconfig, it always sets mac for my newly created ath# with "6" at the place of second digit. I also tried to stop networking service (/etc/init.d/networking stop) and i tried ath5k driver, wich i found unreliable. I didn't find any way to fix all the stuff (may be i missed something up, than gimme a tip and plz sorry). Oh, the distro is debian testing branch.
root@blackusza:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11b ESSID:"" Nickname:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:0 dBm Sensitivity=1/1
Retryff RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/70 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

root@blackusza:~# uname -a
Linux blackusza 2.6.30-1-686 #1 SMP Sat Aug 15 19:11:58 UTC 2009 i686 GNU/Linux
root@blackusza:~# modinfo ath_pci
filename: /lib/modules/2.6.30-1-686/net/ath_pci.ko
license: Dual BSD/GPL
version: svn r4068
description: Support for Atheros 802.11 wireless LAN cards.
author: Errno Consulting, Sam Leffler
srcversion: 5179E97F52752C9A394F7FE
alias: pci:v0000168Cd00009013sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000024sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000023sv*sd*bc*sc*i*
alias: pci:v0000168Cd0000001Dsv*sd*bc*sc*i*
alias: pci:v0000168Cd0000001Csv*sd*bc*sc*i*
alias: pci:v0000168Cd0000001Bsv*sd*bc*sc*i*
alias: pci:v0000168Cd0000001Asv*sd*bc*sc*i*
alias: pci:v0000168Cd00000019sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000018sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000017sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000016sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000015sv*sd*bc*sc*i*
alias: pci:v0000168Cd0000101Asv*sd*bc*sc*i*
alias: pci:v0000168Cd00001014sv*sd*bc*sc*i*
alias: pci:v000010B7d00000013sv*sd*bc*sc*i*
alias: pci:v0000A727d00000013sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000013sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000012sv*sd*bc*sc*i*
alias: pci:v0000168Cd00000007sv*sd*bc*sc*i*
depends: ath_hal,wlan
vermagic: 2.6.30-1-686 SMP mod_unload modversions 686
parm: beacon_cal:int
parm: countrycode:Override default country code. Default is 0. (int)
parm: maxvaps:Maximum VAPs. Default is 4. (int)
parm: outdoor:Enable/disable outdoor use. Default is 0. (int)
parm: xchanmode:Enable/disable extended channel mode. (int)
parm: rfkill:Enable/disable RFKILL capability. Default is 0. (int)
parm: hal_tpcisables manual per-packet transmit power control and lets this be managed by the HAL. Default is OFF. (int)
parm: autocreate:Create ath device in [sta|ap|wds|adhoc|ahdemo|monitor] mode. defaults to sta, use 'none' to disable (charp)
parm: ratectl:Rate control algorithm [amrr|minstrel|onoe|sample], defaults to 'sample' (charp)
parm: intmit:Enable interference mitigation by default. Default is 0. (int)
parm: ath_debug:Load-time driver debug output enable (int)
parm: ieee80211_debug:Load-time 802.11 debug output enable (int)
root@blackusza:~# wlanconfig ath0 destroy
root@blackusza:~# ifconfig wifi0 down
root@blackusza:~# macchanger -m 00:00:00:00:00:00 wifi0
Current MAC: 00:15:af:b2:da:74 (unknown)
Faked MAC: 00:00:00:00:00:00 (Xerox Corporation)
root@blackusza:~# airmon-ng start wifi0

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
PID Name
2298 avahi-daemon
2299 avahi-daemon
2646 dhclient3

Interface Chipset Driver

wifi0 Atheros madwifi-ng
ath0 Atheros madwifi-ng VAP (parent: wifi0) (monitor mode enabled)

root@blackusza:~# macchanger -s ath0
Current MAC: 00:00:00:00:00:00 (Xerox Corporation)
root@blackusza:~# wlanconfig ath1 create wlandev wifi0 wlanmode managed
root@blackusza:~# macchanger -s ath1
Current MAC: 06:00:00:00:00:00 (unknown)
root@blackusza:~# iwconfig ath1 mode managed
root@blackusza:~# iwconfig ath0 mode managed
Error for wireless request "Set Mode" (8B06) :
SET failed on device ath0 ; Invalid argument.