Dear All,

First post here so forgive me if I write this in the wrong place! For the past few weeks I have tried to install madwifi drivers but failed tragically. I think I have tried everything possible so I think it is time to seek help.

Here is the process I followed:

sudo apt-get install linux-headers-$(uname -r)

# aptitude install module-assistant

# module-assistant auto-install madwifi-source

Here is the error I am getting:

ake[2]: Entering directory `/usr/src/modules/madwifi'
Checking requirements... ok.
Checking kernel configuration... ok.
/usr/bin/make -C /usr/src/linux SUBDIRS=/usr/src/modules/madwifi modules
make[3]: Entering directory `/usr/src/linux-headers-'
/usr/src/linux-headers- /usr/src/linux-headers- No such file or directory
make[3]: *** No rule to make target `/usr/src/linux-headers-'. Stop.
make[3]: Leaving directory `/usr/src/linux-headers-'
make[2]: *** [modules] Error 2
make[2]: Leaving directory `/usr/src/modules/madwifi'
make[1]: *** [binary-modules] Error 2
make[1]: Leaving directory `/usr/src/modules/madwifi'
make: *** [kdist_build] Error 2

I have also tried:


make install

but this has failed too!